Contributor
Contributor

Bad XOrg performance - RHEL 5/CentOS 5

I've noticed very poor performance with RHEL 5/CentOS 5. Mouse is choppy when moving. I've noticed that the mouse cursor will have a block of the desktop wallapaper covering it when moving sometimes. Also, mouse scrolling is very slow. Windows are difficult to move too.

0 Kudos
9 Replies
Immortal
Immortal

Do you have Tools installed?

0 Kudos
Contributor
Contributor

Yes, I do. They are running, I have confirmed this.

0 Kudos
Immortal
Immortal

Weird, I just tried this and noticed the same behavior. You should definitely file a bug.

I installed using the rpm package. In my case, for some reason my xorg.conf was missing an entry for the mouse driver. I added

InputDevice "Configured Mouse"

InputDevice "XOrgMouseWorkaround"

to the ServerLayout section and

Section "InputDevice"

Identifier "XOrgMouseWorkaround"

Driver "void"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "vmmouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ps/2"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "true"

EndSection

to the end (I got these from an Ubuntu install with tools, so they might not be tweaked the best for CentOS). Doing this solved the problem for me.

0 Kudos
Contributor
Contributor

Thanks, I'll try this. I've also seen this same behavior (worse) in VMWare Workstation 6.

0 Kudos
Contributor
Contributor

Thank you very much! It's perfect now.

0 Kudos
Contributor
Contributor

etung, thank you very much.

I was running RHEL 5 64bit ( 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:14 EST 2007 x86_64) in Fusion beta 4 and everything was wonderful - EXCEPT for the bizarre mouse behavior, which was bad enough to make it almost useless.

Searching the forum, I found this workaround, and it did the trick for RHEL 5 - I even cut & pasted the sections from your message into xorg.conf exactly as-is.

I noticed in another thread that you had mentioned that this workaround was in beta 4. If so, it apparently is not there for this environment - could it be that the vmware tools install takes a different path due to the x86_64 ? The tools install (actually, upgrade) behaved normally - I used the RPM installer.

In any case, thanks again - I can now use this VM.

0 Kudos
Immortal
Immortal

I noticed in another thread that you had mentioned that this workaround was in beta 4. If so, it apparently is not there for this environment - could it be that the vmware tools install takes a different path due to the x86_64 ? The tools install (actually, upgrade) behaved normally - I used the RPM installer.

I have no idea, can you verify this (clean install of RHEL5, install beta 4 tools, check xorg.conf) and file a bug if the fix isn't there? What version of xorg does RHEL5 use, 7.1/7.2/other?

0 Kudos
Contributor
Contributor

I have no idea, can you verify this (clean install of

RHEL5, install beta 4 tools, check xorg.conf) and

file a bug if the fix isn't there?

Yes, I intended to do a new install anyway. The current VM I am working with was originally installed under beta 3, and then I installed the beta 3 vmware tools - (I didn't make a backup of the VM before installing the beta 3 tools). I will install clean and report the results.

What version of

xorg does RHEL5 use, 7.1/7.2/other?

It's 7.1.1 - here is a copy of the top and bottom of the Xorg log (after doing the patch):

X Window System Version 7.1.1

Release Date: 12 May 2006

X Protocol Version 11, Revision 0, Release 7.1.1

Build Operating System: Linux 2.6.9-34.ELsmp x86_64 Red Hat, Inc.

Current Operating System: Linux JBRHEL51 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:14 EST 2007 x86_64

Build Date: 09 January 2007

Build ID: xorg-x11-server 1.1.1-48.13.el5

Before reporting problems, check http://wiki.x.org

to make sure that you have the latest version.

Module Loader present

Markers: (--) probed, (**) from config file, (==) default setting,

(++) from command line, (!!) notice, (II) informational,

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 13 16:44:40 2007

(==) Using config file: "/etc/X11/xorg.conf"

(==) ServerLayout "single head configuration"

(**) |-->Screen "Screen0" (0)

(**) | |-->Monitor "vmware"

(**) | |-->Device "VMware SVGA"

(**) |-->Input Device "Keyboard0"

(**) |-->Input Device "Configured Mouse"

(**) |-->Input Device "XOrgMouseWorkaround"

<<<< much snipped out >>>>>

(II) VMWARE(0): vmmouse is available

(**) Option "CorePointer"

(**) Configured Mouse: Core Pointer

(**) Option "Device" "/dev/input/mice"

(**) Option "ZAxisMapping" "4 5"

(**) Configured Mouse: ZAxisMapping: buttons 4 and 5

(II) XINPUT: Adding extended input device "XOrgMouseWorkaround" (type: Void)

(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)

(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)

(II) VMWARE(0): VMMOUSE DEVICE_INIT

(II) VMWARE(0): VMMOUSE DEVICE_ON

(II) VMWARE(0): vmmouse enabled

0 Kudos
Contributor
Contributor

I am using VMWare Workstation 6.0 and installed a CentOS 5 guest. After installing vmware-tools (rpm), I found that mouse pointer still does not "integrate" (float around the screen without doing Ctrl-Alt). Editing of /etc/X11/xconf.org according to your message above and the integrated mouse pointer works without issues.

Thanks for your tips. There is definitely something VMWare need to fix in future versions of vmware-tools installation process.

0 Kudos