emcteddyspring
Contributor
Contributor

Attempting to run VMs located on an external USB 3.0 HD crashes OS X.

I'm running Fusion 5.0.3 on Mountain Lion 10.8.2 on my RMBP. Running VMs from the local SSD (256GB) works, but when I attempt to run VMs (either newly created or ones I copy after OS install) from an external NTFS-formatted USB 3.0 hard drive, OS X crashes and reboots. I enabled writing to NTFS by following these instructions. I'm able to read and write to the external hard drive with no issues, in fact it's significantly faster than other USB 2.0 external hard drives I own. Is anybody else having this issue and know how to fix?

Below is the "problem" that was reported:

Interval Since Last Panic Report:  1750551 sec

Panics Since Last Report:          3

Anonymous UUID:                    5A2D1CF8-9021-B27B-10D7-2E043BA8E8AA

Mon Jun  3 10:58:22 2013

panic(cpu 6 caller 0xffffff7f8b3d405d): "fuse4x: mmap being attempted with no region accessibility (flags=0)\n"@/tmp/fuse4x-kext-6INp/kext-fuse4x_0_9_2/fuse_file.h:51

Backtrace (CPU 6), Frame : Return Address

0xffffff80fc933870 : 0xffffff800901d626

0xffffff80fc9338e0 : 0xffffff7f8b3d405d

0xffffff80fc933940 : 0xffffff7f8b3c9f5f

0xffffff80fc933970 : 0xffffff8009110eff

0xffffff80fc9339a0 : 0xffffff80093859c1

0xffffff80fc9339e0 : 0xffffff800905b69d

0xffffff80fc9339f0 : 0xffffff8009066316

0xffffff80fc933ac0 : 0xffffff8009090464

0xffffff80fc933b10 : 0xffffff7f8b3e813d

0xffffff80fc933bd0 : 0xffffff7f8b3e7430

0xffffff80fc933c20 : 0xffffff7f8b3eae15

0xffffff80fc933c50 : 0xffffff7f8b3e5941

0xffffff80fc933d10 : 0xffffff800911f42d

0xffffff80fc933d60 : 0xffffff8009110d94

0xffffff80fc933dd0 : 0xffffff8009107329

0xffffff80fc933e20 : 0xffffff8009349ed3

0xffffff80fc933e50 : 0xffffff80093768c3

0xffffff80fc933f50 : 0xffffff80093e060a

0xffffff80fc933fb0 : 0xffffff80090cdc03

      Kernel Extensions in backtrace:

         org.fuse4x.kext.fuse4x(0.9.2)[DB2DEF63-0070-30C7-9C5F-6B9946A7EC97]@0xffffff7f8b3c9000->0xffffff7f8b3d9fff

         com.vmware.kext.vmx86(104.3.86)[694FF4C3-2540-31A5-BFDA-9312D0767A48]@0xffffff7f8b3e4000->0xffffff7f8b3f0fff

BSD process name corresponding to current thread: vmware-vmx

Mac OS version:

12C2034

Kernel version:

Darwin Kernel Version 12.2.1: Thu Oct 18 12:13:47 PDT 2012; root:xnu-2050.20.9~1/RELEASE_X86_64

Kernel UUID: 3F93B852-872F-3DF0-BCF8-46D48024C422

Kernel slide:     0x0000000008e00000

Kernel text base: 0xffffff8009000000

System model name: MacBookPro10,1 (Mac-C3EC7CD22292981F)

System uptime in nanoseconds: 5424754920747

last loaded kext at 5411571744467: com.vmware.kext.vmioplug.10.1.24 10.1.24 (addr 0xffffff7f8b3f1000, size 32768)

last unloaded kext at 5240506748378: com.apple.driver.AppleFileSystemDriver 3.0.1 (addr 0xffffff7f8b295000, size 8192)

loaded kexts:

com.vmware.kext.vmioplug.10.1.24 10.1.24

com.vmware.kext.vmx86 0104.03.86

com.vmware.kext.vmnet 0104.03.86

com.vmware.kext.vsockets 90.4.23

com.vmware.kext.vmci 90.4.18

org.fuse4x.kext.fuse4x 0.9.2

com.mcafee.kext.Virex 1.1.0d1

com.apple.filesystems.smbfs 1.8

com.apple.driver.AppleBluetoothMultitouch 75.19

com.apple.driver.AppleHWSensor 1.9.5d0

com.apple.driver.AudioAUUC 1.60

com.apple.iokit.IOBluetoothSerialManager 4.1.2f9

com.apple.filesystems.autofs 3.0

com.apple.driver.ApplePlatformEnabler 2.0.6d1

com.apple.driver.AGPM 100.12.81

com.apple.driver.X86PlatformShim 1.0.0

com.apple.driver.AppleMikeyHIDDriver 122

com.apple.driver.AppleHDA 2.3.5fc10

com.apple.driver.AppleUpstreamUserClient 3.5.10

com.apple.GeForce 8.0.6

com.apple.driver.AppleSMCPDRC 1.0.0

com.apple.driver.AppleSMCLMU 2.0.3d0

com.apple.driver.AppleIntelHD4000Graphics 8.0.6

com.apple.iokit.BroadcomBluetoothHCIControllerUSBTransport 4.1.2f9

com.apple.iokit.IOUserEthernet 1.0.0d1

com.apple.Dont_Steal_Mac_OS_X 7.0.0

com.apple.driver.ApplePolicyControl 3.2.13

com.apple.driver.AppleMikeyDriver 2.3.5fc10

com.apple.driver.AppleLPC 1.6.0

com.apple.driver.AppleMuxControl 3.2.13

com.apple.driver.AppleMCCSControl 1.1.11

com.apple.driver.AppleIntelFramebufferCapri 8.0.6

com.apple.driver.AppleUSBTCButtons 237.1

com.apple.driver.AppleUSBTCKeyboard 237.1

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1

com.apple.BootCache 34

com.apple.driver.XsanFilter 404

com.apple.driver.AppleSDXC 1.4.0

com.apple.iokit.IOAHCIBlockStorage 2.3.1

com.apple.iokit.AppleBCM5701Ethernet 3.5.0b9

com.apple.driver.AppleUSBHub 5.5.0

com.apple.driver.AirPort.Brcm4331 612.20.14

com.apple.driver.AppleAHCIPort 2.5.1

com.apple.driver.AppleUSBEHCI 5.5.0

com.apple.driver.AppleUSBXHCI 1.5.1

com.apple.driver.AppleIntelCPUPowerManagementClient 196.0.0

com.apple.driver.AppleEFINVRAM 1.7

com.apple.driver.AppleSmartBatteryManager 161.0.0

com.apple.driver.AppleACPIButtons 1.7

com.apple.driver.AppleRTC 1.5

com.apple.driver.AppleHPET 1.8

com.apple.driver.AppleSMBIOS 1.9

com.apple.driver.AppleACPIEC 1.7

com.apple.driver.AppleAPIC 1.6

com.apple.nke.applicationfirewall 4.0.39

com.apple.security.quarantine 2

com.apple.driver.AppleIntelCPUPowerManagement 196.0.0

com.apple.iokit.IOSCSIBlockCommandsDevice 3.5.5

com.apple.iokit.IOUSBMassStorageClass 3.5.1

com.apple.driver.IOBluetoothHIDDriver 4.1.2f9

com.apple.driver.AppleMultitouchDriver 235.29

com.apple.iokit.IOSerialFamily 10.0.6

com.apple.kext.triggers 1.0

com.apple.iokit.IOSCSIArchitectureModelFamily 3.5.5

com.apple.driver.DspFuncLib 2.3.5fc10

com.apple.iokit.IOAudioFamily 1.8.9fc11

com.apple.kext.OSvKernDSPLib 1.6

com.apple.nvidia.nvGK100hal 8.0.6

com.apple.NVDAResman 8.0.6

com.apple.iokit.AppleBluetoothHCIControllerUSBTransport 4.1.2f9

com.apple.iokit.IOSurface 86.0.3

com.apple.iokit.IOBluetoothFamily 4.1.2f9

com.apple.driver.AppleHDAController 2.3.5fc10

com.apple.iokit.IOHDAFamily 2.3.5fc10

com.apple.driver.AppleSMBusPCI 1.0.11d0

com.apple.driver.AppleGraphicsControl 3.2.13

com.apple.driver.AppleBacklightExpert 1.0.4

com.apple.iokit.IONDRVSupport 2.3.6

com.apple.driver.AppleSMBusController 1.0.11d0

com.apple.driver.X86PlatformPlugin 1.0.0

com.apple.driver.AppleSMC 3.1.4d2

com.apple.driver.IOPlatformPluginFamily 5.3.0d47

com.apple.iokit.IOGraphicsFamily 2.3.6

com.apple.driver.AppleUSBMultitouch 237.3

com.apple.iokit.IOUSBHIDDriver 5.2.5

com.apple.driver.AppleUSBMergeNub 5.5.0

com.apple.driver.AppleUSBComposite 5.2.5

com.apple.driver.AppleThunderboltDPInAdapter 1.8.9

com.apple.driver.AppleThunderboltDPAdapterFamily 1.8.9

com.apple.driver.AppleThunderboltPCIUpAdapter 1.2.6

com.apple.driver.AppleThunderboltPCIDownAdapter 1.2.6

com.apple.driver.CoreStorage 296.10

com.apple.driver.AppleThunderboltNHI 1.6.3

com.apple.iokit.IOThunderboltFamily 2.1.8

com.apple.iokit.IOEthernetAVBController 1.0.2b1

com.apple.iokit.IO80211Family 510.4

com.apple.iokit.IONetworkingFamily 3.0

com.apple.iokit.IOUSBUserClient 5.5.0

com.apple.iokit.IOAHCIFamily 2.3.1

com.apple.iokit.IOUSBFamily 5.5.0

com.apple.driver.AppleEFIRuntime 1.7

com.apple.iokit.IOHIDFamily 1.8.1

com.apple.iokit.IOSMBusFamily 1.1

com.apple.security.sandbox 220

com.apple.kext.AppleMatch 1.0.0d1

com.apple.security.TMSafetyNet 7

com.apple.driver.DiskImages 344

com.apple.iokit.IOStorageFamily 1.8

com.apple.driver.AppleKeyStore 28.21

com.apple.driver.AppleACPIPlatform 1.7

com.apple.iokit.IOPCIFamily 2.7.3

com.apple.iokit.IOACPIFamily 1.4

com.apple.kec.corecrypto 1.0

Model: MacBookPro10,1, BootROM MBP101.00EE.B03, 4 processors, Intel Core i7, 2.4 GHz, 8 GB, SMC 2.3f32

Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 512 MB

Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 1024 MB

Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54333531533642465238432D50422020

Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x80AD, 0x484D54333531533642465238432D50422020

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xEF), Broadcom BCM43xx 1.0 (5.106.98.100.14)

Bluetooth: Version 4.1.2f9 11046, 2 service, 18 devices, 1 incoming serial ports

Network Service: Thunderbolt Ethernet, Ethernet, en3

PCI Card: Apple 57762-A0, sppci_ethernet, Thunderbolt@10,0,0

Serial ATA Device: APPLE SSD SD256E, 251 GB

USB Device: USB 3.0 SATA Bridge, 0x2109  (VIA Labs, Inc.), 0x0700, 0x14a00000 / 2

USB Device: hub_device, 0x8087  (Intel Corporation), 0x0024, 0x1a100000 / 2

USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8510, 0x1a110000 / 3

USB Device: hub_device, 0x8087  (Intel Corporation), 0x0024, 0x1d100000 / 2

USB Device: hub_device, 0x0424  (SMSC), 0x2512, 0x1d180000 / 3

USB Device: BRCM20702 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x1d181000 / 5

USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8286, 0x1d181300 / 6

USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0262, 0x1d182000 / 4

0 Kudos
5 Replies
dlhotka
Champion
Champion

Two things:

1) Upgrade to 10.8.3, it had a HUGE number of bugfixes.

2) The issue is highly likely to be the NTFS format on the external drive.  OSX doesn't support it, and third-party drives are problematic at best.  Reformat the drive as either FAT32 or HPFS+ (Mac format).  I'd avoid exFAT at the moment too, as it's more prone to corruption.  If you use FAT32, your VM's will need to be split into 2GB chunks.

0 Kudos
emcteddyspring
Contributor
Contributor

dlhotka, thanks for the response. I upgraded to 10.8.3 and still get the same error. It does look like it's one of the components I installed to get RW working with NTFS (fuse4x). I guess that I'll use the external drive for VM storage (and only run from the internal HD) for now as I'd prefer to keep the drive formatted NTFS for compatibility.

0 Kudos
dlhotka
Champion
Champion

FAT32 is the most compatible file system out there :-).

But yeah, if you're on 10.8.3, then it definitely looks like it's the NTFS issue.  You may experience issues going through the shared folders function too (since that'll trigger the OSX drivers).  If you can, just mount it directly in the VM.

0 Kudos
WoodyZ
Immortal
Immortal

As a general rule I normally do not write to NTFS Volumes from OS X on a daily basis however I do on occasion and at times write some individual files that are large, 10 to 50 GB and have yet to have any issues.  I normally do not run VM's from the NTFS Volume under OS X although today I played around for a while doing lots of disk activity seeing if it would be problematic and it wasn't.

Now I did not use the same methods you did to enable write support for NTFS under OS X and though I'd share with you what I'm using.  On my newest MacBook Pro I installed just two things, OSXFuse 2.5.5  (2.5.6 has been release since I install 2.5.5 however I've not updated it yet) and the commercial version of Tuxera NTFS for Mac 2012.3.6.

As a general rule I normally keep Tuxera NTFS for Mac disabled and enable it on the fly when I need to write to an NTFS Volume as it is something I do more as the exception not necessarily the rule. However since over the last year I've written a couple terabytes of data, especially very large files to NTFS Volumes from OS X and making sure MD5/SHA1/SHA256 checksums match and have yet to have issues and I consider it safer then using ExtFAT for my use.

0 Kudos
dariusd
Leadership
Leadership

This is a defect or limitation in fuse4x.  Its complaint, "mmap being attempted with no region accessibility", is entirely bogus, since it is specifically permitted to mmap a region with no accessibility.  The documentation for mmap(2) even reveals that there is a defined constant, PROT_NONE, that the caller of mmap should use to request that the region be mapped with no accessibility.  That's what we are doing when this failure occurs in fuse4x.

I would expect that this failure will occur whenever an attempt is made to power on a VM whose .vmem (the file which backs the virtual machine's RAM) is located on a filesystem provided via a version of fuse4x with this problem.

You may be able to work around the problem by using virtual machine config options to move the .vmem file to another volume which does not need fuse4x.  (I don't immediately recall which options... others here might, or I can try to dig them up...)

To really fix this issue, you'll have to find a filesystem driver without this limitation, whether it's a newer version of fuse4x or another filesystem driver altogether.

Cheers,

--

Darius

0 Kudos