Maletti
Contributor
Contributor

Applications on VM (windows) run very slow and laggy

Hello there

I have for some time been struggling with getting my windows (10) VM through VMware Fusion to run smoothly on my MBP (Monterey version 12.1) . I specifically want to run SolidWorks through the VM, but also other small applications. As of now, SolidWorks runs incredibly slow and laggy, the same goes for other applications as google chrome where just typing characters is laggy. The windows 10 OS (cursor, managing files, ...) though appears to run alright, but now sure if these tasks take much CPU.
I have updated to the latest VMware Tools and VM fusion, allocated 5 cores and 8 GB memory to the VM. I am using the shared desktop configuration so all files are shared between my Mac OS and VM OS, if this information matters. 

Specs of my MBP:

Model name: MacBook Pro
Model-id: MacBookPro16,1
Processor name: 6-Core Intel Core i7
Processor: 2.6 GHz
Amount of processors: 1
Amount of cores: 6
L2-buffer (pr. Core): 256 kB
L3-buffer: 12 MB
Hyper-Threading-technology: Activated
Memory: 16 GB

I hope someone in here have had the same issue and can share ways to resolve this. Fingers crossed!

- F

0 Kudos
4 Replies
Technogeezer
Virtuoso
Virtuoso

What happens if you stop using the shared desktop (I assume that means VMware shared folders are in play here) and access all files from the VMs hard drive? VMware shared folders are known to exhibit poor performance. 

0 Kudos
dlhotka
Champion
Champion

There's something odd going on if chrome by itself in the guest is laggy.  I never saw that on my Win10 VM's on the intel machine.

Couple of things:  If you don't have a need for it, disable side channel protection in the VM's advanced settings.  Also set it to always use 3d acceleration, and run it windowed or full screen mode only.

0 Kudos
Maletti
Contributor
Contributor

Yes I thought about that too. I just disabled the shared desktop, but still even chrome runs slow. So that does not seem to be the problem. Thanks for the idea though! Let me know if you have other advices!

0 Kudos
Maletti
Contributor
Contributor

I always run the VM full screen. Where do I set the 3D acceleration ? Thanks!

0 Kudos