VMware Communities
MikeFromABQ
Enthusiast
Enthusiast
Jump to solution

All external USB devices now seen as not recognized by Windows

After recovering from a corrupt VMWAREVM bundle by using the "Copy" option instead of "Move", I had to re-Activate Windows 10 and now USB drives that can currently be read by all other machines including Mac and Windows, get the message "USB device not recognized" when I plug it into the MacBook Pro running macOS 10.15.7 and choose to see it in the guest VM with Windows 10.

In Windows Device Manager, all these devices then appear with a warning "Unknown USB Device (Invalid Device Descriptor)" only in this VM and not on any other machines.

I have followed the uninstall steps for VMWare 11.5.7 and reinstalled it and all the VMWare Tools.  Nothing I have done has changed anything about the result.

Based on this article: https://kb.vmware.com/s/article/57195

I note that in macOS System Preferences | Security & Privacy | General, I no longer see the option (that I remember seeing at some point in the past) to click on "Allow" to enable 'System software from developer  "VMWare, Inc"'.

There is also NO message like this: "System software from developer VMWare, Inc. was blocked from loading".

I have NOT tried adding the following line to the VMX file:

usb.generic.keepStreamsEnabled = "FALSE"

I have the ZIP file of information gathered with verbose USB messages enabled, if that would help.

Next step?

Reply
0 Kudos
1 Solution

Accepted Solutions
MikeFromABQ
Enthusiast
Enthusiast
Jump to solution

Solved: The last step that made it work was found in 

https://kb.vmware.com/s/article/1027964

 

  • Shutdown the Virtual Machine
  • Click on Virtual Machine > Settings > USB & Bluetooth
  • At the bottom of the pane click on Advanced USB options
  • Remove and re-add the USB controller
  • Start the Virtual Machine.

and it's unknown if any of the prior processes were also needed.

 

View solution in original post

2 Replies
MikeFromABQ
Enthusiast
Enthusiast
Jump to solution

Solved: The last step that made it work was found in 

https://kb.vmware.com/s/article/1027964

 

  • Shutdown the Virtual Machine
  • Click on Virtual Machine > Settings > USB & Bluetooth
  • At the bottom of the pane click on Advanced USB options
  • Remove and re-add the USB controller
  • Start the Virtual Machine.

and it's unknown if any of the prior processes were also needed.

 

Technogeezer
Immortal
Immortal
Jump to solution

<redacted my reply since you did exactly what I was going to recommend>

Glad you found a solution.

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides