lucasbernadsky
Hot Shot
Hot Shot

VCF 4.3 vCenter upgrade prechecks fail with bundle error

Hi everyone. I am trying to upgrade vCenter to 7.0 U2c from SDDC Manager but when I ran the prechecks i get an error regarding the bundle.

I tried deleting the bundle and redownloading it but it keeps sending the same error.

 

Bundle Precheck - VMWARE_SOFTWARE 4.9.14-146064

"Bundle level precheck for VCENTER failed with exception : ConstraintValidationException: Structure com.vmware.appliance.subtask_info has a union that is missing a required field for this case: end_time"

 

Did anyone faced this issue and solved it? I already raised a SR so hopefully they will help me find the solution and I will update this post.

Thanks

0 Kudos
2 Replies
viquarhcimca
Enthusiast
Enthusiast

Hey worth sharing the lcm.log or lcm-debug.log from sddc . was this issue fixed if yes how please do share . 

Thanks & Regards,

Mohammed Viquar Ahmed
0 Kudos
lucasbernadsky
Hot Shot
Hot Shot

Well, the precheck didn't pass but I launched the upgrade and it worked. So not sure about what was causing this.

Maybe there was a version mismatch between vCenter and SDDC Manager, which can be changed

 

1) Take a snapshot of SDDC Manager (Preferably when powered off)

2) SSH to SDDC Manager and switch to root

3) psql -h localhost -U postgres -d platform -c "select id, vm_name, version from vcenter;"

4) psql -h localhost -U postgres -d platform -c "UPDATE vcenter SET version = '*Version*' WHERE id = '*ID*';"

Tags (1)
0 Kudos