abuzzi
Enthusiast
Enthusiast

VCF 4.0 -Host 10.58.6.181 found zero SSD devices for SSD cache tier.

Jump to solution

Hello,

I had to perform a new bringup of my vcf4.0 but getting now these errors:

Host 10.58.6.181 found zero SSD devices for SSD cache tier.

Host 10.58.6.182 found zero SSD devices for SSD cache tier.

Host 10.58.6.183 found zero SSD devices for SSD cache tier.

Host 10.58.6.184 found zero SSD devices for SSD cache tier.

This is what I see on ESXi 10.58.6.181:

[root@esxi181:~] esxcli storage core device list | grep naa.55

naa.55cd2e41514663e7

   Display Name: Local ATA Disk (naa.55cd2e41514663e7)

   Devfs Path: /vmfs/devices/disks/naa.55cd2e41514663e7

naa.55cd2e4151466962

   Display Name: Local ATA Disk (naa.55cd2e4151466962)

   Devfs Path: /vmfs/devices/disks/naa.55cd2e4151466962

[root@esxi181:~] vdq -qH -d naa.55cd2e41514663e7 | grep IsCapacityFlash

IsCapacityFlash?:  0

[root@esxi181:~] vdq -qH -d naa.55cd2e4151466962 | grep IsCapacityFlash

IsCapacityFlash?:  1

[root@esxi181:~] partedUtil getptbl /vmfs/devices/disks/naa.55cd2e41514663e7

gpt

116737 255 63 1875385008

[root@esxi181:~] partedUtil getptbl /vmfs/devices/disks/naa.55cd2e4151466962

gpt

116737 255 63 1875385008

[root@esxi181:~]

other esxi shows same informations.

Why the builder node validation complains about "found zero SSD devices for SSD cache tier" ?

How can I set that ?

Thx,

A.

1 Solution

Accepted Solutions
abuzzi
Enthusiast
Enthusiast

Hello,

I give a try on having both naa.** set as "IsCapacityFlash: 0":

[root@esxi181:~] vdq -q

[

   {

      "Name"     : "naa.55cd2e41514663e7",

      "VSANUUID" : "",

      "State"    : "Eligible for use by VSAN",

      "Reason"   : "None",

      "IsSSD"    : "1",

"IsCapacityFlash": "0",

      "IsPDL"    : "0",

      "Size(MB)" : "915715",

   "FormatType" : "512e",

   },

   {

      "Name"     : "mpx.vmhba32:C0:T0:L0",

      "VSANUUID" : "",

      "State"    : "Ineligible for use by VSAN",

      "Reason"   : "Has partitions",

      "IsSSD"    : "0",

"IsCapacityFlash": "0",

      "IsPDL"    : "0",

      "Size(MB)" : "30432",

   "FormatType" : "512e",

   },

   {

      "Name"     : "naa.55cd2e4151466962",

      "VSANUUID" : "",

      "State"    : "Eligible for use by VSAN",

      "Reason"   : "None",

      "IsSSD"    : "1",

"IsCapacityFlash": "0",

      "IsPDL"    : "0",

      "Size(MB)" : "915715",

   "FormatType" : "512e",

   },

]

[root@esxi181:~]

And the " vSAN Disk Availability (AllFlash)" is now marked as "Success"

Weird since I was under the impression that having two equal disk size would imply to tell the builder which one has to use as capacity so the other was cache....

Anyway this did the trick for me...

Thx,

A.

View solution in original post

0 Kudos
3 Replies
GreatWhiteTec
VMware Employee
VMware Employee

If you already did a bring-up, you will need to clean up those hosts as they most likely have vSAN partitions on the drives.

You may also need to clean up your network.

See my blog post on cleanup commands. Hope this helps.

https://greatwhitetec.com/2020/02/19/devices-unavailable-for-vsan/

A+, DCSE, MCP, MCSA, MCSE, MCTS, MCITP, MCDBA, NCDA, NCIE-SAN, NCIE-BR, VCP4, VCP5, VCP5-DT, VCAP5-DCA _____________________ If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful.
abuzzi
Enthusiast
Enthusiast

Hello,

here the suggested commands run on esxi181 (same output on esxi182/183/184).

Basically I see both naa disks eligible for vsan, with no current vsanuid present:

[root@esxi181:~] vdq -q

[

   {

      "Name"     : "naa.55cd2e41514663e7",

      "VSANUUID" : "",

      "State"    : "Eligible for use by VSAN",

      "Reason"   : "None",

      "IsSSD"    : "1",

"IsCapacityFlash": "0",

      "IsPDL"    : "0",

      "Size(MB)" : "915715",

   "FormatType" : "512e",

   },

   {

      "Name"     : "mpx.vmhba32:C0:T0:L0",

      "VSANUUID" : "",

      "State"    : "Ineligible for use by VSAN",

      "Reason"   : "Has partitions",

      "IsSSD"    : "0",

"IsCapacityFlash": "0",

      "IsPDL"    : "0",

      "Size(MB)" : "30432",

   "FormatType" : "512e",

   },

   {

      "Name"     : "naa.55cd2e4151466962",

      "VSANUUID" : "",

      "State"    : "Eligible for use by VSAN",

      "Reason"   : "None",

      "IsSSD"    : "1",

"IsCapacityFlash": "1",

      "IsPDL"    : "0",

      "Size(MB)" : "915715",

   "FormatType" : "512e",

   },

]

[root@esxi181:~]

[root@esxi181:~] esxcli vsan storage remove -s naa.55cd2e41514663e7

Unable to remove device: Disk naa.55cd2e41514663e7 is not a vSAN SSD.

[root@esxi181:~] esxcli vsan storage remove -s naa.55cd2e4151466962

Unable to remove device: Disk naa.55cd2e4151466962 is not a vSAN SSD.

[root@esxi181:~]

[root@esxi181:~] esxcli vsan cluster get

vSAN Clustering is not enabled on this host

[root@esxi181:~] esxcli vsan cluster leave

The host is not in a vSAN cluster.

[root@esxi181:~]

What else I can try to make the vcf builder node happy during its vsan preliminary check ?

Thx,

A.

abuzzi
Enthusiast
Enthusiast

Hello,

I give a try on having both naa.** set as "IsCapacityFlash: 0":

[root@esxi181:~] vdq -q

[

   {

      "Name"     : "naa.55cd2e41514663e7",

      "VSANUUID" : "",

      "State"    : "Eligible for use by VSAN",

      "Reason"   : "None",

      "IsSSD"    : "1",

"IsCapacityFlash": "0",

      "IsPDL"    : "0",

      "Size(MB)" : "915715",

   "FormatType" : "512e",

   },

   {

      "Name"     : "mpx.vmhba32:C0:T0:L0",

      "VSANUUID" : "",

      "State"    : "Ineligible for use by VSAN",

      "Reason"   : "Has partitions",

      "IsSSD"    : "0",

"IsCapacityFlash": "0",

      "IsPDL"    : "0",

      "Size(MB)" : "30432",

   "FormatType" : "512e",

   },

   {

      "Name"     : "naa.55cd2e4151466962",

      "VSANUUID" : "",

      "State"    : "Eligible for use by VSAN",

      "Reason"   : "None",

      "IsSSD"    : "1",

"IsCapacityFlash": "0",

      "IsPDL"    : "0",

      "Size(MB)" : "915715",

   "FormatType" : "512e",

   },

]

[root@esxi181:~]

And the " vSAN Disk Availability (AllFlash)" is now marked as "Success"

Weird since I was under the impression that having two equal disk size would imply to tell the builder which one has to use as capacity so the other was cache....

Anyway this did the trick for me...

Thx,

A.

View solution in original post

0 Kudos