VasanthanB
Contributor
Contributor

Unable to add VxRail Node on vSAN stretch cluster (VCF on VxRail 4.3.0)

Environment: VCF 4.3.0 (on VxRail 7.0.202).

I am trying the usecase of vSAN stretch case of site-A and site-B scenario.

1.Deployed Site-A workload domain (with 3 VxRail Node) and vSAN stretch configuration between Site-A & Site-B  network configuration has been completed and Site's are accessible both underlay and overlay (over BGPEVPN)

2.Site-B: Same Mgmt VLAN,VxRail Infra VLAN has been created. Site-A VxRail Mgr discovered the Site-B connected VxRail nodes (from VxRailMgr plugin on external vCenter)

But SDDC Mgr ->Workload Domain->Cluster->Add VxRail host doesnot discovered any vxrail node:

"Failed to load Host cluster details. No new VxRail hosts discovered for cluster with name "

 

Followed the 4.3.0 RN workaround of "Adding a VxRail cluster with hosts spanning multiple racks to a workload domain fails"

i.e adding the VxRail nodes from VxMgr Plugin (from vCenter) and validation success,but its failed add the VxRail Node with below error

A general system error occurred: Server closed connection after 0 response bytes read; <SSL(<io_obj p:0x00007fb9fc04c4b8, h:72, <TCP '192.168.11.43 : 50184'>, <TCP '192.168.21.51 : 443'>>)>"

192.168.11.43 => As my vCenter and  192.168.21.51 as my VxRail Node.

 

0 Kudos
3 Replies
cathalp
Contributor
Contributor

To stretch a cluster for VCF on VxRail a script needs to be used from SDDC manager, details are located in the Dell Solve procedure and also in the VCF on VxRail Admin guide here..

https://docs.vmware.com/en/VMware-Cloud-Foundation/4.3/com.vmware.vcf.vxrail.admin.doc/GUID-45CD54CD...

The order of operations is as follows:

1. Run the script to prepare for stretching, this creates Hosts and VM rules for AZ1.

2. Add the nodes to AZ2, as you should have Layer 3 routed vSAN you need to use the Add Node Proxy feature in VxRail (this is covered in the VxRail Solve procedure)

3. Finally run the script to stretch the cluster

 

VasanthanB
Contributor
Contributor

Hi,

I have followed the above procedure for Rack Expansion scenario and Expanding Rack vxrail node validation was successful by while adding to VxRail cluster thrown below error.

A general system error occurred: Server closed connection after 0 response bytes read; <SSL(<io_obj p:0x00007fbcf811b888, h:99, <TCP '192.168.11.40 : 55234'>, <TCP '192.168.21.51 : 443'>>)>

where:

192.168.11.40 as external vCenter / 192.168.21.51 as VxRail node on Site-2(AZ2).

 

 

 

Thanks,

Vasanthan

0 Kudos
cathalp
Contributor
Contributor

So just to understand the failure is occurring when you add the nodes to the cluster using the Vxrail plugin and not the second step when adding the nodes to the VCF cluster?


If the error is occurring when adding the nodes using the VxRail plugin you would need to check the Vxrail logs for a more meaningful error, these logs are located in /var/log/microservice_log, the dayone.log or short.term.log should have a more descriptive error.

0 Kudos