Sreeharimr
Contributor
Contributor

Cloud builder validation error.

Jump to solution

I am trying to do a VCF deployment over VXRail "Two vDS with custom profile and NIC level redundancy".

The VXRail is having 2x25G onboard ports(vmnic0 and vmnic1) and 2 x 25G ports in PCI Card(vmnic2 and vmnic3).

 

Part of VXRail Deployment, One System VDS is created with vmnic0 and vmnic2 as uplink1 and uplink2.

 

For VCF deployment, to create Overlay VDS, we are assigning vmnic1 and vmnic3.

 

But during the cloud builder validation, it fails with error "Incorrect set of vmnics provided for host".

1 Solution

Accepted Solutions
shank89
Expert
Expert

do you happen to have a mix of uppercase and lower case or even just upper case in your hostnames?  If so, change this to all lower and see if your problem persists.

Shashank Mohan

VCIX-NV 2022 | VCP-DCV2019 | CCNP Specialist

https://lab2prod.com.au
LinkedIn https://www.linkedin.com/in/shankmohan/
Twitter @ShankMohan
Author of NSX-T Logical Routing: https://link.springer.com/book/10.1007/978-1-4842-7458-3

View solution in original post

5 Replies
viquarhcimca
Enthusiast
Enthusiast

Ideal way of doing it , when you do VxRail bring up u will have to use VMNIC0 and VMNIC1. for VxRail VDS . 

when u fill the parameter sheet , u will select VMNIC0 and VMNIC1 for VxRail VDS and Select Profile 3 for 2nd VDS with VMNIC 2 and VMNIC 3 for nsx-t vds. 

 

Thanks & Regards,

Mohammed Viquar Ahmed
Tags (1)
0 Kudos
shank89
Expert
Expert

do you happen to have a mix of uppercase and lower case or even just upper case in your hostnames?  If so, change this to all lower and see if your problem persists.

Shashank Mohan

VCIX-NV 2022 | VCP-DCV2019 | CCNP Specialist

https://lab2prod.com.au
LinkedIn https://www.linkedin.com/in/shankmohan/
Twitter @ShankMohan
Author of NSX-T Logical Routing: https://link.springer.com/book/10.1007/978-1-4842-7458-3
wangtao2134
Contributor
Contributor

I touch the same error,how did you solve it?

many thanks.

0 Kudos
Sreeharimr
Contributor
Contributor

The Host listed in vCenter Cluster view was displayed as lowercase, but when checked inside the TCP properties for the Hostname, noticed that it was having a mix of uppercase and lower case. Changed it and it solved the issue.

JoshuaVMW
Contributor
Contributor

 

UPDATE:  within a few minutes of my post, I was able to follow your lead and solved my issue. 

just to clarify for others that may run into the same scenario and problem. 

how ever it shows under vcenter cluster, that whats need to be on your worksheet and TCP/configuration. 

(In vCenter UI)

Select HOST > CONFIGURE > RCP/IP conifguration > EDIT Default stack > HOST NAME field -- match the cases of your host. 

THANK YOU ALL

 

"Hello all, i am having the exact same error -- also doing the same scenario.

where is the TCP properties? on NIC? or just the host Configure/TCP-IP ?

did you make the change on TCP properties or on the vcf worksheet? "

0 Kudos