VMware Cloud Community
CKretsinger
Contributor
Contributor
Jump to solution

Management Pack for vCloud Director (vROps) Adapter connection/authentication issue?

Good Morning,

I'm trying to configure the Management Pack for vCloud Director (Cloud Management Marketplace | Solution Exchange) and I seem to be having trouble with the most simple thing. I've got the Solution installed and mostly configured, but for some reason it either wont reach out and get to the vCD server, or its having some kind of authentication issues. When I test the adapter with proper credentials (local, and LDAP in vCD), I get the error:

Unable to establish a valid connection to the target system. Failed to Login ! using Host=<FQDN> User=<adminuser>@System

Is the adapter putting the @System after it, or is this something so simple I'm over thinking it. I'd be happy to post any kind of logs if needed, just let me know what you need.

Thanks a ton!

Reply
0 Kudos
1 Solution

Accepted Solutions
mark_j
Virtuoso
Virtuoso
Jump to solution

You shouldn't NEED to put @system, as it should work with or without. is the public REST API base URL assigned within vCloud Director? See the installation manual, page 28..

Have you checked for open firewall ports between the Analytics VM and vCloud Director host?

If you find this or any other answer useful please mark the answer as correct or helpful.

View solution in original post

Reply
0 Kudos
2 Replies
mark_j
Virtuoso
Virtuoso
Jump to solution

You shouldn't NEED to put @system, as it should work with or without. is the public REST API base URL assigned within vCloud Director? See the installation manual, page 28..

Have you checked for open firewall ports between the Analytics VM and vCloud Director host?

If you find this or any other answer useful please mark the answer as correct or helpful.
Reply
0 Kudos
CKretsinger
Contributor
Contributor
Jump to solution

Just to clarify for those who run into the same issue. I had pointed the REST API to the wrong IP address when doing NAT translation. When I removed the API URL from the Administration>System Settings>Public Addresses, the authentication worked. Changing the NAT translation rule to the correct IP address and putting the REST API back into the configuration resolved the issue.

Thanks Mark, I knew it was something I had overlooked a hundred times, I appreciate it!

Reply
0 Kudos