amashi
Contributor
Contributor

vCO 5.1 webservice through SOAP

Jump to solution

I am unable access vCO webservices through SOAP protocol in Wavemaker.I get the premature end of file! error when i try using the following url;

http://vcoserver-ip-address:8280/vmware-vmo-webcontrol/webservice?WSDL.

Version of vCO : 5.1
Version of wavemaker : 6.5.2Release.

I have attached the screenshot of the error.
Can i get the solution for this.?

0 Kudos
1 Solution

Accepted Solutions
Burke-
VMware Employee
VMware Employee

That error indicates that the certificate for vCO has not yet been imported to the Wavemaker server's certificate store. Please reference Christian's post here for instructions on that part of the process:

http://mighty-virtualization.blogspot.com/2012/09/wavemaker-handling-ssl-certificates.html

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter

View solution in original post

0 Kudos
11 Replies
admin
Immortal
Immortal

Hi amashi,

this happens because vCO 5.1 redirects the http to https (just check the URL in the browser). So you need the HTTPS connection (8281 port) and a correct certificate Smiley Happy

best regards

Christian

0 Kudos
amashi
Contributor
Contributor

hi,

i have tried with https also. But it does not work work.. can you just tell me how to work with certificates. As in, how to generate and use it?.

0 Kudos
Burke-
VMware Employee
VMware Employee

I wrote an article on working with vCO over SSL that was in turn published as a KB on VMware's site and referenced on Christian's blog...

First result on Google when searching for "vco ssl" : http://www.vcoteam.info/learn-vco/work-with-vco-over-ssl.html ... this article takes you step by step through the process of creating a self signed certificate that matches the hostname Smiley Happy

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
0 Kudos
amashi
Contributor
Contributor

thank you so much..

ill try this and get back to you.

0 Kudos
amashi
Contributor
Contributor

hi Burke,

Smiley Sad I followed the link which you gave but dint work for me.. Smiley Sad I have attached the screenshot of error.. Please help me out with this..

thanks

0 Kudos
Burke-
VMware Employee
VMware Employee

That error indicates that the certificate for vCO has not yet been imported to the Wavemaker server's certificate store. Please reference Christian's post here for instructions on that part of the process:

http://mighty-virtualization.blogspot.com/2012/09/wavemaker-handling-ssl-certificates.html

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
0 Kudos
amashi
Contributor
Contributor

my vco and wavemaker are on the same machine.. i am not able to find /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents path..

thanks

0 Kudos
Burke-
VMware Employee
VMware Employee

Oh right Christian's article looks like the paths for OSX, which is what I'm using... You may want to review:

http://dev.wavemaker.com/forums/?q=node/4423

Which points to: http://tomcat.apache.org/tomcat-4.0-doc/ssl-howto.html

I've seen some other discussions here in the communities where others were trying to get WaveMaker to talk to vCO over SSL and they were able to.. for example: http://communities.vmware.com/message/2199036 -- I have not done this myself though.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
0 Kudos
Burke-
VMware Employee
VMware Employee

I just tested this on a Windows XP VM I booted up... Assuming you have already updated your vCO Server with a certificate that has a CN matching the FQDN, then here's what you need to do on the WM server (Windows based):

- Stop your WM services

- export a copy of your certificate from the vCO server using a browser ( I used Firefox pointed at https://<my vco server>:8281/

- (your path may vary here) Import the certificate to the cacerts keystore on the WM server, on my Windows machine, this was done as follows:

c:\Program  Files\WaveMaker\6.5.2.Release\jdk-1.6.0_24\jre\bin\keytool.exe -import  -alias vco51.vcoteam.lab -file "C:\Documents and  Settings\Administrator\My Documents\Downloads\vco51.vcoteam.lab.crt"  -storepass changeit -keystore "C:\Program  Files\WaveMaker\6.5.2.Release\jdk-1.6.0_24\jre\lib\security\cacerts"

when I was prompted to accept the fingerprints, I typed "yes" and hit <ENTER>, then received:
Certificate was added to keystore

Next, I started my WM Services again and tried to import the SOAP webservice: SUCCESS.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
amashi
Contributor
Contributor

when i export the certificate from vco server through browser i get it in .cer format.. how to get it in .crt format?

0 Kudos
amashi
Contributor
Contributor

hey bruke

Thanks a ton.. It worked for me.. Smiley Happy Smiley Happy

0 Kudos