AreThereAnyUniq
Contributor
Contributor

SQL Plug-in: Add a database workflow

Jump to solution

I'm trying to add a database object to Orchestrator's SQL plug-in's inventory using the Add a database workflow.  It fails with the following exception:  com.vmware.o11n.plugin.database.DatabaseException: com.microsoft.sqlserver.jdbc.SQLServerException: Login failed for user 'domainname\username'. (Dynamic Script Module name : addDatabase#8).

I suspect the problem is with the Connection URL.  I've tried jdbc:sqlserver://servername.domainname.net:1433;databaseName=master and jdbc:sqlserver://servername.domainname.net:1433.

I'm new to Orchestrator so its possible I'm missing something simple.  The SQL plug-in is installed.  I know the account I'm using has rights to the database because I can log into SQL Studio Management and run a query against the master database.  Any ideas?

0 Kudos
1 Solution

Accepted Solutions
Burke-
VMware Employee
VMware Employee

In the workflow library is a JDBC URL Creator workflow, have you tried using that to figure out the JDBC url you need? That's what I have done in the past when I had trouble with the URLs...

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter

View solution in original post

0 Kudos
3 Replies
Burke-
VMware Employee
VMware Employee

In the workflow library is a JDBC URL Creator workflow, have you tried using that to figure out the JDBC url you need? That's what I have done in the past when I had trouble with the URLs...

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
0 Kudos
marcseitz
Enthusiast
Enthusiast

Hey,

I believe we've had the same trouble with a MS SQL-Server.

Try to set the SQL-Server to a fixed port instead of a dynamic Port Mapper.

Port 1433 is the danymic Port mapper of SQL. Go to the SQL-Server Configuration and change the TCP/IP-Setting to a fixed Port.

Try your JDBC-URL with the fixed Port - Should be working fine..

Regards,

Marc

0 Kudos
AreThereAnyUniq
Contributor
Contributor

That worked!  It took me a couple of tries but it did return the url I needed to use.  The database is now in my inventory.  Thank you!

0 Kudos