KRAEMS
Enthusiast
Enthusiast

Error updating vRO appliance from version 7.3 to 7.4

Hello Experts,

I am trying to update an existing vRO appliance from version 7.3 to version 7.4, but am receiving the following error when I try to install the updates:

Vendor: VMware Inc.

Appliance Name: VMware vRealize Orchestrator Appliance

Appliance Version: 7.3.0.21553 Build 5521409 (Details...)

Last Check:

Wednesday, 2018 July 25 11:03:20 UTC-4

RPM Status 1: Pre install script failed, package test and installation skipped.

Post-install: failed

Orchestrator database validation failed. See logs for more details.

Update failed (code 1-1). Check logs in /opt/vmware/var/log/vami or retry update later.

Last Install:

Failed to install updates(Error while running pre-install scripts and post-install scripts) on Wednesday, 2018 July 25 11:05:02 UTC-4

RPM Status 1: Pre install script failed, package test and installation skipped.

Post-install: failed

Orchestrator database validation failed. See logs for more details.

Update failed (code 1-1). Check logs in /opt/vmware/var/log/vami or retry update later.

- /opt/vmware/var/log/vami/updatecli.log seemed to have the most information, but, nothing there sounded any alarms beyond the text above. 

- the appliance in question *seems* fine, otherwise.  I can open the 7.3 Workflow Designer against it, it shows my workflows, I can run workflows. 

- the 'Validate Configuration' option on the Control Center page does not indicate any issues. 

Any input/feedback/insight is most appreciated.  Thank you. 

KRAEMS

0 Kudos
3 Replies
sbeaver
Leadership
Leadership

Are you using the internal Postgress database or are you using an external database?  Is the vRO appliance part of a cluster or a stand alone configuration?

Steve Beaver
VMware Communities User Moderator
VMware vExpert 2009 - 2020
VMware NSX vExpert - 2019 - 2020
====
Co-Author of "VMware ESX Essentials in the Virtual Data Center"
(ISBN:1420070274) from Auerbach
Come check out my blog: [www.virtualizationpractice.com/blog|http://www.virtualizationpractice.com/blog/]
Come follow me on twitter http://www.twitter.com/sbeaver

**The Cloud is a journey, not a project.**
0 Kudos
iiliev
VMware Employee
VMware Employee

We had a few customers experiencing 7.4 upgrade issues due to duplicate records in the database (in 7.4 we hardened table constraints a bit due to some requirements related to multi-tenancy support). I guess it's possible that you are hitting the same kind of issue.

There should be some traces in the vRO and/or appliance logs although I can't recall at the moment in which log file(s) exactly.

0 Kudos
KRAEMS
Enthusiast
Enthusiast

@sbeaver:

Internal PostGres DB with a stand-alone configuration.  Thanks. 

KRAEMS

0 Kudos