VMware Cloud Community
rlabinot
Enthusiast
Enthusiast

Gitlab blueprint doesn't trigger event topic "Blueprint configuration" for Extensibility

Author : pgilday

URL : http:////docs.vmware.com/en/vRealize-Automation/8.1/Using-and-Managing-Cloud-Assembly/GUID-CA30B6E8-...

Topic Name : Create an extensibility subscription

Publication Name : Using and Managing vRealize Automation Cloud Assembly

Product/Version : vRealize Automation/8.1

Question :

When I create a new blueprint on an integrated Gitlab in vRA Cloud Assembly, it doesn't trigger the event "Blueprint configuration" as extensibility.

This event should be triggered because a new blueprint has been created from Gitlab. I made another test and tried to create manually a blueprint directly from the Web Interface in vRA and it detected the new blueprint.

Strange that from the Gitlab, it's not working and detecting...  Any help ?

Reply
0 Kudos
2 Replies
rlabinot
Enthusiast
Enthusiast

Here is the subscription that should detect a new blueprint from Gitlab :

pastedImage_0.png

It detects only new blueprint created from the web interface but not from Gitlab.

Here is an example when it detects new blueprint from Web interface :

pastedImage_1.png

Here is the view of blueprints :

pastedImage_2.png

The difference I see, is the "updated by" field which is "system-user" when it is from Gitlab. Is it linked to the problem ?

pgilday
VMware Employee
VMware Employee

Thanks for your question - I've forwarded your inquiry to the IX person who wrote that topic.

Reply
0 Kudos