ssecuro
Contributor
Contributor

"Unable to connect to the MKS: Failed to connect to server xxx.xxx.xxx.xxx:902

Hi good day, I installed 4.0 when I connect esxi and I click on the console I get segiguiente reading "Unable to connect to the MKS: Failed to connect to server xxx.xxx.xxx.xxx: 902. As the basis?

25 Replies
ssecuro
Contributor
Contributor

how to solve this?

0 Kudos
AndreTheGiant
Immortal
Immortal

Your client is in the same network of your ESXi?

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
ssecuro
Contributor
Contributor

yes, This started to install when VCenter Guided Consolidation

0 Kudos
admin
Immortal
Immortal

It might be blocked ports.

Check out this KB 1012382 TCP and UDP Ports for vCenter Server, ESX hosts, and other network components management acc...

Rick Blythe

Social Media Specialist

VMware Inc.

0 Kudos
ssecuro
Contributor
Contributor

maybe the port is blocked on how esxi check if you have?

0 Kudos
a2alpha
Expert
Expert

MKS is mouse keyboard screen, I had this when a vm vmotioned and i was connected to a console or if i was using the keyboard and mouse on another vm when I open up the new console.

As other people have said check the ports are open but also have a look in the hosts logs.

0 Kudos
ssecuro
Contributor
Contributor

The only problem I have with esxi 4.0, I have other servers with esxi 3.5 and I have no problems with them

0 Kudos
andosm
Enthusiast
Enthusiast

Hi,

please check if your VI Client can resolve hostname of your new ESX 4.0 host.

If not, add your new ESX 4.0 host name to DNS or local hosts file on your VI Client. Then remote console should work Smiley Happy

--

Pozdrawiam/Best Regards

Andrzej

Pozdrawiam/Best Regards Andrzej
0 Kudos
aaudu
Contributor
Contributor

I'm having the same issues when I try to connect from to an ESXi 4.0 Server using the VMWare vShpere Client. Once I start the Virtual Machine I create and navigate to the console tab I get the "Unable to connect to the MKS: Failed to connect to server xxx.xxx.xxx.xxx:902" error message.

I've tried editing the config file to reflect vmauthd.server.alwaysProxy = TRUE, but that was already in the the config file. Any suggestions? ideas?

Cheers

0 Kudos
aaudu
Contributor
Contributor

I'm having the same issues when I try to connect from to an ESXi 4.0

Server using the VMWare vShpere Client. Once I start the Virtual

Machine I create and navigate to the console tab I get the "Unable to

connect to the MKS: Failed to connect to server xxx.xxx.xxx.xxx:902"

error message.

I've tried editing the config file to reflect

vmauthd.server.alwaysProxy = TRUE, but that was already in the the

config file. Any suggestions? ideas?

What method would you recommend to be certain the ports are open. I've checked and they seem to be unless I'm missing something.

Cheers

0 Kudos
tianyiyuancn
Contributor
Contributor

I just resolved this problem. The reason is the ESX server used domain name in VC,so connected to it is failed,chage it to ip addr. everything is ok. Before it ,I try lots of methods to make it,but failed,include added some commands in ESX console, added permited ports on firewall,etc.

0 Kudos
matt4130
Contributor
Contributor

This is correct. Add the ESX hosts to either the local hosts file or to DNS

marburg
Contributor
Contributor

I have the same problem. Actually it all worked fine for ages, but recently it fails. I also did enter the hostname and FQDN inkluding the IP in the hosts file, but somehow I can't make a console connection to 2 ESX servers with v4.0 that are managed by a vCenter server. I also have a standalone host (which is somehow unwilling to be integrated in the VI) and there it works fine. Many changes have been made since I did try this the last time, so I can't really tell which action could have caused this. One major change was the update of the hosts from ESX 3.5 to 4, vCenter server to v4 and the VI client to vSphere client v4.

The necessary ports are open. The domain is also right, what else could it be? 😐

Some more information: It looks like I'm the only one who's affected, other workstations in the same network don't have this problem. So it seems to be some config issue system, but I'm kind of stumped here...

0 Kudos
marburg
Contributor
Contributor

Ooops, posted in the wrong thread... sorry

Post changed by marburg

0 Kudos
zakk
Contributor
Contributor

Hi.

I had this trouble ,too. but I resolved this the other day.

Did you configure "Virtual LAN" in the VMkernel on physical server console by pressing F2 key?

(the Virtual LAN above is not the VLAN used by Guest OS)

If you configured this, you should check Default Gateway IP of Viretual LAN.

It would be appreciated if it could help you.

0 Kudos
StewartCollins
Contributor
Contributor

see this post for resolution:  http://communities.vmware.com/message/2198503

0 Kudos
encino
Contributor
Contributor

I am also getting this message.  With me though the Vcenter server is in the root domain.  So its in ABC.COM and my machine is in Child.ABC.com.  I already put the server name in my local host file and that is not working.

If I go to a machine that is part of ABC.COM I do not get this error.

Any help would be appreciated. 

0 Kudos

This issue was happened because you have not enabled port TCP/902, UDP 902 in your esx server. if your enabled, then just ask your network team to enable this port from the firewall. I had the same issue and i found that  the issue was these ports had been  blocked by the firewall . if you are using your home pc Lab please disable all the firewalls on your pc. 

0 Kudos
uwish
Enthusiast
Enthusiast

Check this out and see if might help you....

VMware KB: Cannot open the virtual machine console

0 Kudos