fgw
Contributor
Contributor

how to configure vcb pre/post backup script timeouts

searching for this for days now, but finally gave up!

where can i change the vcb pre and postscript backup script timeouts?

whats the maximum values it can be set to?

have seen the recommendation to change this timeouts in various posts and documents, but never found a way that worked!

tried

<vpxd> .... .... <task> <timeout>1200</timeout> </task> </vpxd>

in vpxd.cfg but this had no effect.

using vcb 1.5, esxi 3.5u4 and vc 2.5u4 in a san environment.

trying to run defrag and cleanup in my pre backup script but snapshot creation times out. need to increase the timeout here ...

0 Kudos
1 Reply
fgw
Contributor
Contributor

to answer my own question:

had opened a SR at vmware support and got the following answer and also was referred to the KB article below:

add the following to

/etc/opt/vmware/vpxa/vpxa.cfg on every ESX server already connected to virtual center

and to

C:\Documents and Settings\All Users\Application Data\VMware\VMware VirtualCenter\vpxd.cfg on the virtual center server

<config> . . .

<task> <timeout>10800</timeout> </task> <vmomi> <soapStubAdapter> <blockingTimeoutSeconds>10800</blockingTimeoutSeconds> </soapStubAdapter> </vmomi>

</config>

in the above example the value of 1800 corresponds to a timeout value of 30 minutes.

after changing the files you need to restart vmware-vpxa service on each host AND virtual center server service on the virtual center server.

the reason to add this to the hosts AND virtual center, is this information is passed from virtual center to a host when it is added to virtual center. i was not able to verify this yet, but will do as soon as i have hardware available.

there is a knowledge base articles KB 1004790 which explains how to change the timeout and referres to two other articles explaining how to restart the services.

although the problem described in this article is not exactly what i was aking for, the solution worked for changing the VCB pre/post backup timeouts!

from my tests, changing the task timeout alone would solve my problem while changing the vmomi timeout alone had no effect on the VCB pre/post backup timeouts at all.

as the recommendation from vmware support was to change both timeouts and i have no idea what the vmomi timeout is for, i will implement both timeouts.

if anybody has some additional info pls reply!

thanks

0 Kudos