afrontera
Contributor
Contributor

esxi instalation fails. Loading module sata_nv

Hi all

im trying to install ESXi on a HP Compaq DX2450. My sata controller is an Nvidia Nforce430 (MCP61). When the installer runs fails saying "The installation operation.....blablabla". When a take a look on the log, i can see this:

'VmkCtl' warning. Loading module sata_nv failed. Exec of command /sbin/mvkload_mod /mod/sata_nv.o succeded, but returned with non-zero status. 1

Failed to load module 'sata_nv': Invalid argument.

Simple.map

10de:03e7 0000:0000 storage sata_nv

10de:03f6 0000:0000 storage sata_nv

10de:03f7 0000:0000 storage sata_nv

10de:045c 0000:0000 storage sata_nv

10de:045d 0000:0000 storage sata_nv

10de:045e 0000:0000 storage sata_nv

10de:045f 0000:0000 storage sata_nv

10de:0555 0000:0000 storage sata_nv

10de:07f8 0000:0000 storage sata_nv

pci.ids

037e MCP55 SATA Controller

037f MCP55 SATA Controller

03e7 MCP61 SATA Controller

03f6 MCP61 SATA Controller

03f7 MCP61 SATA Controller

045c MCP65 SATA Controller

045d MCP65 SATA Controller

045e MCP65 SATA Controller

045f MCP65 SATA Controller

0555 MCP67 SATA Controller

07f8 MCP73 SATA Controller

lspci outputs

-


00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)

00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)

-


00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)

Subsystem: Hewlett-Packard Company Unknown device 2a72

Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 16

Memory at fe02d000 (32-bit, non-prefetchable)

I/O ports at fc00

Capabilities: Power Management version 2

Capabilities: Message Signalled Interrupts: Mask+ 64bit+ Queue=0/3 Enable-

Capabilities: HyperTransport: MSI Mapping

00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2) (prog-if 85 )

Subsystem: Hewlett-Packard Company Unknown device 2a72

Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 19

I/O ports at 09f0

I/O ports at 0bf0

I/O ports at 0970

I/O ports at 0b70

I/O ports at f700

Memory at fe02c000 (32-bit, non-prefetchable)

Capabilities: Power Management version 2

Capabilities: Message Signalled Interrupts: Mask- 64bit+ Queue=0/2 Enable-

-


00:07.0 0680: 10de:03ef (rev a2)

Subsystem: 103c:2a72

Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17

Memory at fe02d000 (32-bit, non-prefetchable)

I/O ports at fc00

Capabilities: Power Management version 2

Capabilities: Message Signalled Interrupts: Mask+ 64bit+ Queue=0/3 Enable-

Capabilities: HyperTransport: MSI Mapping

00:08.0 0101: 10de:03f6 (rev a2) (prog-if 85 )

Subsystem: 103c:2a72

Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 18

I/O ports at 09f0

I/O ports at 0bf0

I/O ports at 0970

I/O ports at 0b70

I/O ports at f700

Memory at fe02c000 (32-bit, non-prefetchable)

Capabilities: Power Management version 2

Capabilities: Message Signalled Interrupts: Mask- 64bit+ Queue=0/2 Enable-

Capabilities: HyperTransport: MSI Mapping

Any idea?

Thx

0 Kudos
20 Replies
eversdn
Contributor
Contributor

thank you,moderator,now i know that how the ESXi load the drivers,we only need join the new driver into the oem.tgz,thank for your help,and i rebuild the oem.tgz now,i would upload the files over again.

could you tell me what is the kernel edtion of ESXi3.5u3 ?

the driver is released

i have join the Community Unified Driver Pack and the nforce c61 sata drivers ..

People, I have a Dell Inspiron 531 and It works fine.

Thanks a lot!

0 Kudos