drdyno
Enthusiast
Enthusiast

esxi 3.5 VIC remote console connection refused

I have an esxi 3.5 update 2 /refresh server running 2 virtual machines, XP and Ubuntu 8.04. No VC in use.

If I run VIC from LAN, everything works fine.

If I run VIC from WAN, everything except console works fine.

I have the following redirect on my router, which enabled me to access the esxi host from remote,

other

Enabled

443 ~ 443

192.168.1.10

443 ~ 443

Both

but, to my dismay, the console says:

Cannot connect to host xx.xxx.xxx.xx: No connection could be made because the target machine actively refused it.

I've been coming the communities and forums, but have not nailed down a solution-

Any guidance is appreciated...

-Bruce

0 Kudos
11 Replies
Dave_Mishchenko
Immortal
Immortal

Hello Bruce, the remote console connection is made over port 903. http://communities.vmware.com/servlet/JiveServlet/download/2500-1-4915/VI3.5%20ports.jpg

0 Kudos
drdyno
Enthusiast
Enthusiast

Dave,

I have added the following port forward to my list, but still have the same problem.

other2

Enabled

903 ~ 903

192.168.1.10

903 ~ 903

Both

However, it does seem that the error pops up much quicker now.

further advice?

0 Kudos
Dave_Mishchenko
Immortal
Immortal

Are you using NAT?

0 Kudos
drdyno
Enthusiast
Enthusiast

I'm sorry, I can't see where to look for that,

under, settings, adapter type it says "flexible"?

0 Kudos
drdyno
Enthusiast
Enthusiast

Wait, I suspect I am using bridged, since my vm's have different addresses than the server.

Should I be using NAT? and, if so do I have to convert the vm's to change it?

-Bruce

0 Kudos
Dave_Mishchenko
Immortal
Immortal

I was wondering if the IP for the ESXi host had been NATed. The IPs for the VMs won't be a factor.

0 Kudos
drdyno
Enthusiast
Enthusiast

The host (esxi 3.5) has its own address, provided by dhcp from the router. (192.168.1.10)

0 Kudos
Dave_Mishchenko
Immortal
Immortal

Is that the same IP you use to access the host with the VI client?

0 Kudos
drdyno
Enthusiast
Enthusiast

I don't understand?

The host is esxi, running on bare metal address is 192.168.1.10

ubuntu is 192.168.1.16

xp is 192.168.1.13

the only other address is the wan side address of my router 70.xxx.xx.xx

am I missing something?

I have another computer on the network which I am using now, and has the VIC, address is 192.168.1.3

TIA

0 Kudos
Dave_Mishchenko
Immortal
Immortal

I just wanted to check that you weren't using a 70 IP to access the ESXi host. Just checked by systems and it is port 902 (and not 903 I have posted above) for the remote console.

0 Kudos
drdyno
Enthusiast
Enthusiast

902 is the winner!

Thank you much Dave,

now I can go to sleep!

-Bruce:)

0 Kudos