HarisB
Contributor
Contributor

Stateless PXE booted 3.5i U3 can not have HA agent ?

Hi all,

I have 5 PXE booted stateless 3.5i U3 servers which are experiencing "An error occurred during configuration of the HA agent on the host.", and one 3.5i U3 server installed with local storage where HA works just fine. All servers have exact same settings, and all DNS resolution is ok. I'm 99.9% certain it is because HA agent is not transferred to stateless ESX servers on PXE boot. This is similar to VMware Tools, they are not copied either, and so installation of vmtools on VMs running on those stateless servers fails. It succeeds on local storage ESX server.

I have tried to include vmtools to PXE boot files in the past but files are nowhere to be found after the boot, as there is no local storage, only iSCSI LUNs. I know that if someone can come up with a way to deploy either vmtools or HA agent on PXE boot, I can use the same method to deploy the other component too.

Does anyone have any idea how to do this?

Thanks

0 Kudos
2 Replies
Texiwill
Leadership
Leadership

Hello,

Moved to ESXi forum.


Best regards,

Edward L. Haletky

VMware Communities User Moderator

====

Author of the book 'VMWare ESX Server in the Enterprise: Planning and Securing Virtualization Servers', Copyright 2008 Pearson Education.

SearchVMware Blog: http://itknowledgeexchange.techtarget.com/virtualization-pro/

Blue Gears Blogs - http://www.itworld.com/ and http://www.networkworld.com/community/haletky

As well as the Virtualization Wiki at http://www.astroarch.com/wiki/index.php/Virtualization

--
Edward L. Haletky
vExpert XIV: 2009-2022,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos
gi-minni
Contributor
Contributor

Hi HarisB,

the problem by running ESXi stateless is the complete absence of a persistence layer for the OS.

I spent a lot of time to figure out what is impacted using ESXI in a stateless manner. But I succeed.

By adding an ESXi host to a VIC Server the vpxa agent is tranferred to the ESXi Box. This agent is the only one that

will be installed on demand. If you look at boot time you will read a message similar to "Starting vpxa agent ..."

Now you must know that at the time you add an ESXi host to a VIC-Server a vpxa password will be always

generated and inserted into the /etc/shadow file (took long to figure this out). But the shadow file will

not survive a pxe-boot process and you endup with errors.

Try to insert the /etc/shadow file into a tgz file (e.g. local.tgz) and vpxa remains always connected.

Before this please look if you have an vpxa user in your /etc/passwd file and /etc/chkconfig.db show you

that vpxa is installed. There must be at the end /etc/opt/init.d/vmware-vpxa

If this is not the right answer please ssh into your box and look at /var/log/vmware/vpx/vpxa.log or

/var/log/vmware/hostd.log there you can find useful information how to react on certain problems.

IMHO is a waste of time and resource to try to pxe-boot a system and downloading more than 200MB

just in case I need to be able to update the box. I worked out another feasible way for me. Try to download the

Tools (linux.iso, windows.iso, netware.iso, solaris.iso, freebsd.iso and VMware-viclient.exe) to your

persistent datastore, then you could download the iso or exe file pointing to the address of the ESXi box

and browse the own datastore to download the files. Inside your VM you can mount the iso as loopback

device (Linux) or use WinImage to open an iso file (Windows) and extracting all this files and making a zip

or even better a selfextracting zip of it. So you can easily deploy the zip file and install them on your VM if needed.

Please consider to award points if this was a useful answer to your question

0 Kudos