VMware Cloud Community
T_Reiss
Contributor
Contributor
Jump to solution

RH EL 4.6 64Bit -> Your CPU does not support long Mode?

Hi,

i try to create a RH EL Linux 4.6_64bit Guest on an HP DL585G1 Server with ESX3i Build 123629.

After boot of the Guest i get only his Message: "Your CPU does not support long Mode. Use a 32 bit Distribution"

The crazy thing is, when i boot the ServerHardware direkt with that RH EL Install CD, the Installer runs fine!

So what's going on here?

Any Hint's?

Thank You

Thomas

Reply
0 Kudos
1 Solution

Accepted Solutions
ivp2k9
Enthusiast
Enthusiast
Jump to solution

You likely need to check if:

a) You are running a "proper" (in terms of 64-bit guest support) revision CPU (e.g., several AMD chips were officialy ranked "non-kosher" by VMWare due to improper segmentation support) -- see http://kb.vmware.com/selfservice/viewContent.do?externalId=1901 for details.

b) AMD-V / Pacifica (VT if it were an Intel CPU) is not turned off in computer BIOS.

View solution in original post

Reply
0 Kudos
8 Replies
ivp2k9
Enthusiast
Enthusiast
Jump to solution

You likely need to check if:

a) You are running a "proper" (in terms of 64-bit guest support) revision CPU (e.g., several AMD chips were officialy ranked "non-kosher" by VMWare due to improper segmentation support) -- see http://kb.vmware.com/selfservice/viewContent.do?externalId=1901 for details.

b) AMD-V / Pacifica (VT if it were an Intel CPU) is not turned off in computer BIOS.

Reply
0 Kudos
AntonVZhbankov
Immortal
Immortal
Jump to solution

Enable VT in BIOS


---

VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, HPE ASE, MCITP: SA+VA, VCP 3/4/5, VMware vExpert XO (14 stars)
VMUG Russia Leader
http://t.me/beerpanda
ivp2k9
Enthusiast
Enthusiast
Jump to solution

I believe the topicstarter can not turn on VT -- HP DL585G1 being a part of HP AMD offering....

Again, apart from Pacifica issue -- things could be worse -- some AMD CPUs, hi-end Opteron inclusive, are just totally lokosher for VMWare Smiley Sad

2Topic Starter:

install lshw by typing (as root)

yum -y install lshw

into the server -- and look for CPU description there vs whatever is written in VMware kb 1901 article.

Reply
0 Kudos
Cooldude09
Commander
Commander
Jump to solution

That was nice information sharing...

Anil Gupta

Don’t fear changes, its constant in life, reduce your ecological footprint……………………..Go Green

if you found my answer to be useful, feel free to mark it as Helpful or Correct.

Looking for a Virtualization Solution, look here.....

If U find my answer useful, feel free to give points by clicking Helpful or Correct.

Subscribe yourself at walkonblock.com

Reply
0 Kudos
T_Reiss
Contributor
Contributor
Jump to solution

Hi,

thank your for Help.

I think a) was the correct answer, because this was one of the first Opteron of HP so i think it is a very old CPU Revision (Opteron 848 before Revision E).

VMware's CPU ID Tool show's me, the 64-bit long Mode is supportet, but 64-bit VMware not!

I didn't find elsewere the exactly CPU Revision.

Only this Info from CPU ID Tool:

ExtFam:0 Fam:f ExtMod:0 Mod:5 Stp:8

I loose....

Thank You.

Reply
0 Kudos
T_Reiss
Contributor
Contributor
Jump to solution

I didn't have this Option.

It is an older Machine...

Reply
0 Kudos
T_Reiss
Contributor
Contributor
Jump to solution

I didn't have this Option.

It is an older Machine...

Reply
0 Kudos
ivp2k9
Enthusiast
Enthusiast
Jump to solution

Family 0xF model 0x5 stepping 0x8 looks like Opteron rev C (at least, as of source code of some free *NIXes, like opensoloaris at http://cr.opensolaris.org/~gavinm/webrev-interim-20070801/raw_files/new/usr/src/uts/i86pc/os/cpuid.c.... Which leaves 64-bit guests out of VMware on that chip Smiley Sad

Lo siento.

Reply
0 Kudos