Ripzz
Contributor
Contributor

Problems with x86-64 guest's OS in ESXi 3.5

Jump to solution

VMWare ESXi Server 3i, 3.5.0, build 123629

Hardware:

Motherboard - Intel DP35DP (whith latest BIOS update)

CPU - Intel Core2Duo E8500

RAM - 8gb Samsung

2 x Network adapters Intel

Problems with installing 64-bit guest OS. Messages - your processor does not support 64 bit addressing. Why? 32-bit OS installs and work fine.

Help me please!

0 Kudos
1 Solution

Accepted Solutions
SuryaVMware
Expert
Expert

Make sure you have intel VT enabled in the System BIOS. You need to reboot the ESX server get in to BIOS and look for CPU Options/Features.

You should find the Intel VT/Virtualization technology, Most of the CPUs these days support it but disabled by default in BIOS.

Hope this helps.

-Surya

View solution in original post

0 Kudos
6 Replies
SuryaVMware
Expert
Expert

Make sure you have intel VT enabled in the System BIOS. You need to reboot the ESX server get in to BIOS and look for CPU Options/Features.

You should find the Intel VT/Virtualization technology, Most of the CPUs these days support it but disabled by default in BIOS.

Hope this helps.

-Surya

View solution in original post

0 Kudos
Ripzz
Contributor
Contributor

Yes. Thanks. BIOS setting "Virtualization technology" will be disable Smiley Sad

close thread.

0 Kudos
ocheeslice
Contributor
Contributor

Do you know if enabling VT in BIOS will cause problems with Solaris 10 (32-bit) vm powering on after enabling this feature?

0 Kudos
DSTAVERT
Immortal
Immortal

Should not be a problem.

-- David -- VMware Communities Moderator
0 Kudos
ocheeslice
Contributor
Contributor

Unfortunately, I have this problem. I can no longer create Solaris 10 (32 bit) systems. The installer gets up to the end of disk one, prompts for disk two then reboots and as the system is powering back on it just goes to a black screen and powers it self back off.

Do you have any ideas why did is doing this now?

FOUND A SOLUTION:

well, this keeps getting weird.

I went into Edit Settings --> Options Tab --> Guest Operating Systems (Versions Drop down) --> changed from Solaris 10 (32 bit) to Solaris 10 (64 bit) and now it works again. I don't know how, this is a 32 bit ISO install. I don't know how my production Solaris 10 (32 bit) will handle being changed to a (64 bit) but I'll post the results when I'm brave enough to try rebooting it.

0 Kudos
admin
Immortal
Immortal

I don't know how, this is a 32 bit ISO install.

Solaris 10 has one ISO for both 32-bit and 64-bit installs. It automatically installs a 64-bit OS on 64-bit capable hardware. See KB 1975 for instructions on forcing Solaris to use 32-bit mode on 64-bit capable hardware.

0 Kudos