Highlighted
Enthusiast
Enthusiast

Problems with NFS

Jump to solution

I am trying to share a directory on Windows 2003 using NFS to an ESXi 3.5 server. I get the error "Cannot open volume: /vmfs/volumes/...." I believe this is a problem with not having user name mapping setup on my windows 2003 machine. I have read other comments that have been posted about copying the password file from the ESX machine to the Windows 2003 server but with ESXi 3.5 I do not know how to copy files over.

0 Kudos
1 Solution

Accepted Solutions
Highlighted

I just tried on my system and the other accounts show up OK. I'm running Windows Services for Unix 3.5 and my origial passwd file came from ESX 3.0 but I just copied over the file from 3i b82664. I followed the process above to get the file. Do you see 5 accounts when you open it on Windows?

The AD authenication is for inbound connection - i.e. with the VI client. Don't think that would help you here as the connection from ESX to NFS is made with the root account. ESX 3.5 has the Virtual Machine Delegate option which you can use to specify the account that will be use to access NFS shares, but that option seems to be missing in 3i.

View solution in original post

0 Kudos
15 Replies
Highlighted
Immortal
Immortal

You can use this:

Or this:

Or upload them via the datastore (browse datastore, upload / download links are at the top of that window).

0 Kudos
Highlighted
Enthusiast
Enthusiast

What file should I be uploading or downloading? When I open my datastore all I see are virtual machines.

0 Kudos
Highlighted

Hi Jason, if this is a test system, then you can login at the ESXi console and copy the files to a vmfs datastore on the host. You can then browse the datastore and get the files with the VI client.

1) At the ESXi console, press ALT-F1

2) The screen will switch to show some text. Type in unsupported and press enter. You won't see the text as you type it. You should then be prompted for the root password.

3) Enter cd /etc

4) Run ls and you'll see the files you want. You can copy them with a command like this - cp passwd /vmfs/volumes/<datastore name>/passwd

5) You'll now be able to see them with the datastore browser.

Highlighted
Enthusiast
Enthusiast

Now that I have the passwd file on my windows machine when I add it to the Microsoft Services for NFS and click the List UNIX Users I get &lt;unmapped&gt; UID = -2. It does not show any of the other accounts. When I open the file I see all the default accounts. I still receive the same error stated before.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Would it be possible to just use active directory to access NFS share on Windows 2003 by using this document?

0 Kudos
Highlighted

I just tried on my system and the other accounts show up OK. I'm running Windows Services for Unix 3.5 and my origial passwd file came from ESX 3.0 but I just copied over the file from 3i b82664. I followed the process above to get the file. Do you see 5 accounts when you open it on Windows?

The AD authenication is for inbound connection - i.e. with the VI client. Don't think that would help you here as the connection from ESX to NFS is made with the root account. ESX 3.5 has the Virtual Machine Delegate option which you can use to specify the account that will be use to access NFS shares, but that option seems to be missing in 3i.

View solution in original post

0 Kudos
Highlighted
Enthusiast
Enthusiast

I have attached some screen shots of what I get. I do not see the 5 user names. If I open the passwd file in notepad I do see the accounts listed.

0 Kudos
Highlighted
Enthusiast
Enthusiast

I think I figured out the problem, I had to have the passwd file in both the group and the user box..

0 Kudos
Highlighted
Enthusiast
Enthusiast

So now that I have this working on one ESXi 3.5 server will it not work on the other ones due to different passwd files on each ESXi 3.5 servers?

0 Kudos
Highlighted

You'd need to have the root pasword set to the same thing.

Highlighted
Contributor
Contributor

I have the password file in both the group and user box but I don't see all the ESX names. I still have &lt;unmapped&gt; -2. Please help

0 Kudos
Highlighted
Contributor
Contributor

Nevermind this link explains the process in great detail.

0 Kudos
Highlighted
Contributor
Contributor

Thank you. I couldn't find a way to get the passwd file off of the ESXi server to finish my R2 NFS setup. Now it is working with your help on the Alt-F1 tip Smiley Happy

0 Kudos
Highlighted
Contributor
Contributor

Hi,

I just need to mount a NFS from an ESXi server to a Windows 2003 with NFS server enabled. I have followed every steps to recover password and groups files on ESXi server then import them into the 2003 server.

I've mapped the local administrator account with the root one with no problem.

On the ESXi server The first Network interface got the VM Kernel and Vswitch on the same Lan as the 2003 NFS server... Then can access each other i've check.

Every time I try to mount the NFS store I've got the error like "error during the configuration of the host: Cannot open volumes: /vmfs/volumes/5ce4b7xxxxx" (random number each time)

On the Windows NFS server I've got

04-02-2009 12:04:18 MOUNT SUCCESS 192.168.xx.xxx F:\Bobafett_DataStore

04-02-2009 12:04:18 UMOUNT SUCCESS 192.168.xx.xxx F:\Bobafett_DataStore

04-02-2009 12:09:21 MOUNT SUCCESS 192.168.xx.xxx F:\Bobafett_DataStore

04-02-2009 12:09:21 UMOUNT SUCCESS 192.168.xx.xxx F:\Bobafett_DataStore

And so on... Is there some logs on the ESXi where I can try to find an answer to my issue... Maybe someone have an idea???

Thanks in advance.

0 Kudos
Highlighted
Contributor
Contributor

Hi,

I was able to set up an NFS share from Win2003R2 and create a datastore in ESXi4 without having to set up user mappings. I initially had the same problem as other people wherby when trying to add nfs storage in vi / vsphere client I would get the error "error during the configuration of the host: Cannot open volumes: /vmfs/volumes/5ce4b7xxx" but I found if you go to the security tab on the shared folder on the windows server and give full permissions to "ANONYMOUS LOGIN", it all works perfectly... no user mappings or winscp file copies required Smiley Wink

Hope this helps,

BAM.

0 Kudos