Flyerflow
Contributor
Contributor

Problem with Management Agent on ESXi 3.5 U2

Hello,

I'm writing this post because I didn't find my answer on other posts...Since yesterday, I had a problem with my ESX. I saw some strange things on Graphs. I did some search using my VI Client which crashed some times... I have no idea why. I just wanted to restart the management agent on the server and I'm not able to make it works anymore... It seems I have a problem with hostd which generate the following error message when I try to start it (even manually) :

Stopped Proxy service

Accept on client connection failed: Operation was canceled

Stopped Proxy service

Proxy service stopped.

Accept on client connection failed: Operation was canceled

Exception: Assert Failed: "adapterServer != __null" @ /build/mts/release/bora-110271/bora/vim/lib/public/vmomi/server.h:1071

Backtrace:

eip 0x10dbe57e

eip 0x10c816e9

eip 0x10c348d5

eip 0x10c3501e

eip 0x10c35271

eip 0x86c0893

eip 0x10c53d17

eip 0x86c88be

eip 0x86c51c1

eip 0x10c53d17

eip 0x10c416f6

eip 0x10c417b1

eip 0x10c3faba

eip 0x10c53d17

eip 0x81a635c

eip 0x10c3bba5

eip 0x11251604

eip 0x10c34795

eip 0x10dead4e

eip 0x1000aff0

eip 0x112513ac

eip 0x1123dbf5

eip 0x81a2431

Anyone already experience this ?How can I fix this problem and make my VI Client working again ?

Last thing; How can I manage machines on the server without the client / web interface !? As command line are limited...

Thanks in advance

0 Kudos
2 Replies
Flyerflow
Contributor
Contributor

I just saw my /etc/vmware/hostd/vmInventory.xml file is empty... Can this be a source of this prob ?

Should I populate it myself ?

Thanks

0 Kudos
comne
Contributor
Contributor

берем дефолтный environ.tgz с работающей системы и копируем его в файловую систему /vmfs/volume/Hypervisor1/environ.tgz

затем в консоли выбираем Reset System Configuratoin, перезагружаемся

устанавливаем настройки сети и перезапускаем управляющие сервисы.

у меня после этого VI Client заработал.

---

take on the default environ.tgz with a working system and copy it to the file system / vmfs/volume/Hypervisor1/environ.tgz

then in the console select Reset System Configuratoin, reboot

install the network settings and restart the managed services.

I then VI Client earned

0 Kudos