VMware Cloud Community
BOSS_Advisors
Contributor
Contributor

Issue with "Your CPU does not support long mode. Etc.."

Hello, everyone.

I had an issue with installing a Centos 5.2 64 bit (using a Centos released DVD iso) on a ESXi 3.5 host on both Dell PE 440 SC and PE 2950 III. Accoring to their bios, both of these PEs support 64 bit (Intel EM64T). I created a Linux guest using the RedHat Enterprise Linux 5 64bit option. As soon as I started the installation, Centos said " Your CPU does not support long mode. Use a 32bit distribution". I tried different isos to be sure that they were not corrupted.

Have anyone seen this issue before? Please advise.

Thanks.

Reply
0 Kudos
9 Replies
TomHowarth
Leadership
Leadership

Shut down your host and reboot it into the BIOS, once in there have a look in advanced and enable VT extensions. exit saving changes and Cold Boot your Host you will then be able to install your 64bit Guest. if there is no option for VT extensions, and checking on the DELL website does not show a updated BIOS you will be out of luck in running 64 Bit guests

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

Tom Howarth

VMware Communities User Moderator

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
BOSS_Advisors
Contributor
Contributor

Thanks, Tom.

Yes. I am aware of different settings into the BIOS. I already did that enabling VT in the BIOS. It still does not work.

Reply
0 Kudos
achvn
Enthusiast
Enthusiast

Hi,

Not sure that would change anything but I did install CentOS 64 bit successfully choosing the "Ubuntu Linux 64 bit" version as guest operating system. That's an appliance and the documentation specified to use that option.

Maybe you should give it a try.

BOSS_Advisors
Contributor
Contributor

Thanks for the sugguestion. Give that a try.

I didn't mention this in my previous posts. but I was able to install a 64-bit Ubuntu sucessfully on another PE2950/ESXi.

Thanks.

Reply
0 Kudos
admin
Immortal
Immortal

Can you please post a vmware.log file from the VM that fails to enter long mode?

Reply
0 Kudos
RParker
Immortal
Immortal

This is 100% guaranteed, no doubt a 64-bit problem with a setting. Either something is not set correctly in the BIOS of that machine (if it indeed IS in fact a 64-bit processor) or you setup the VM originally as 32-bit then changed to 64-bit.

Ensure that your VM is set correctly, or simply delete the vmx and start over, because it's one of the 2 issues, I can guarantee it.

Reply
0 Kudos
TdeGouw
Contributor
Contributor

I can confirm this issue on a dual quadcore Dell 2950 using vmware ESXi 3.5.0 build 110271 using a CentOS 4.7 x86_64 dvd iso image.

Trying to get a virtual machine as "Redhat Enterprise Linux 4.0 (64-bit)" will cause the error to occur, while creating an "Ubuntu 64-bit" will install sucessfully.

To as an advice : Try creating a different VM.

Reply
0 Kudos
Sky-Knight
Contributor
Contributor

I am running a CentOS 5.2 64bit install on my ESXi box right now!

However, I have seen the error you're getting and I traced it back to a checkbox in the VM's config. You need to shutdown the VM, right click on it and edit settings. Then on the Options tab, select Paravirtualization in the Advanced category and uncheck the "Support VMI Paravirtualization" checkbox.

Also, just for the record I used the "Other Linux 64-bit" template to get my server working. I ran into this error when I tried to use the "Red Had Enterprise 5.x Linux 64bit" template as well...

Reply
0 Kudos
LenV
Contributor
Contributor

Worked for me on a Dell PowerEdge 1950 running ESXi 4.0. Thanks!

Reply
0 Kudos