rcflyer2005
Contributor
Contributor

Embedded spaces in appliance file causes ovftool error.

I downloaded ubuntu 8.10 server appliance. The .vm files have spaces in them. For example, "Ubuntu 8.10 Server.vmdk." When I run the following command to convert the files to .ovf, I get an error because of spaces in the file name:

ovftool C:\temp\VMWareAppliances\Ubuntu810Server\Ubuntu8.10Server\Ubuntu 8.10 Server.vmx C:\temp\VMWareAppliances\

Ubuntu810Server\Ubuntu8.10Server\Ubuntu 8.10 Server.ovf

Unexpected option: Server.vmx

I tried the following to resolve the "spaces" issue:

1. Remove the spaces from the file names.

2. Edit the .vmx file and removed spaces where the file names are referenced.

3. Reran ovftool to create ovf file.

4. Attempted to import the appliance and got the following error: "An error occurred while parsing the ovf descriptor: Unable to parse xml element 'Envelope'.

The ovf file is attached.

Any help in resolving the spaces issue in the file name would be greatly appreciatede. Thanks much.

Cheers.

Tags (1)
0 Kudos
3 Replies
DSTAVERT
Immortal
Immortal

You could try running the converter tool against the appliance. The Converter tool is available for windows or linux. It is a GUI tool however. It is often necessary to run it more than once getting it to one format and then to ESXi. I have encountered the same problem more than once.

Anyone who uses linux should know how ugly spaces are in names. I usually find I can have a fresh version up and installed far quicker than struggling with a poorly implemented appliance.

If this was created for Workstation it might be possible to launch in player and convert from within.

-- David -- VMware Communities Moderator
bohnsackj
Contributor
Contributor

You will need to put "'s around you paths. Like below.

ovftool "C:\temp\VMWareAppliances\Ubuntu810Server\Ubuntu8.10Server\Ubuntu 8.10 Server.vmx" "C:\temp\VMWareAppliances\

Ubuntu810Server\Ubuntu8.10Server\Ubuntu 8.10 Server.ovf"

0 Kudos
jimtech17
Contributor
Contributor

I'm having this same problem too on a Windows VM with no spaces in the path or file name and I used both the ovftool and the standalone converter. I'm still experimenting with different methods but one would hope these tools would work the way they were intended.

0 Kudos