gicti
Enthusiast
Enthusiast

Admission Check failed for Memory Resource

Hi Everyone,

Just applied update Build: 82664 ESXi 3.5 and now I'm only able to start one VM. I have tested changing the settings to see if I could launch one additional VM, but I am unable. The error message in the subject line is all I get.

0 Kudos
41 Replies
RParker
Immortal
Immortal

Increase the reservation for the memory pool. Otherwise you are probably trying to commit too much memory from the VM for the available resources you have on the ESX hosts/cluster

0 Kudos
gicti
Enthusiast
Enthusiast

I attempted to increase the reservation, but no luck, still getting the error message. Is there a default value, I have not had to touch any of these settings....

0 Kudos
RParker
Immortal
Immortal

Well if you increase the memory limit, the VM settings are set to automatic with no reservation, and you increased the reservation limit, then maybe you are over your memory size commit from the resource pool or the cluster. Try moving the VM to the root of the cluster (not assigned to ANY pool) then try to power it on and see what you get.

gicti
Enthusiast
Enthusiast

Thanks for all your help with with this ...

This is a single server, so I don't have many options. Not running VC. Good thing this is a lab server. That part that is most interesting is I only get this issue after 1 vm is running. I have started other VMs which start but as soon as I go to the second vm it fails.

0 Kudos
kjb007
Immortal
Immortal

Check the resource settings on your virtual machines. I've seen in my scenario, that the CPU and Memory resources, somehow, now included limits/reservation changes. They havent' caused me any problems yet, but they may be doing so for you.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
ocremel
Hot Shot
Hot Shot

How much physical memory do you have on the host ?

0 Kudos
gicti
Enthusiast
Enthusiast

Added more memory to host and problem went away.

0 Kudos
twooten
Contributor
Contributor

Was anyone able to figure this out? I'm having the same issue.

Thanks

0 Kudos
KhanStPreest
Contributor
Contributor

I'm having the same issue. The physical host has "only" 1GB of RAM but the two small Linux VMs I'm trying to run concurrently are only configured for a mere 64MB each. I can start either one by itself but they will not run concurrently. With one VM running the physical host summary shows only 422 of 1021 MB in use, so I'm really surprised that another rinky dink 64MB machine can't start when 500+ MB shows available. I'm new to ESX so perhaps I'm just missing something, open to any insights.

Khan

0 Kudos
twooten
Contributor
Contributor

I was able to get it resolved. I configured the VM to use 2 processors. When I changed it to use one...the problem went away.

Thanks

0 Kudos
KhanStPreest
Contributor
Contributor

Glad that worked for you. Both of my piddly VMs are already configured for only one vCPU so I'm still scratchin' my head as to why they won't run concurrently.

Regards, Khan

0 Kudos
twooten
Contributor
Contributor

Hi Khan

spoke too soon I think!!!!! LOL

I have since created another VM and it's giving me the same error.

Will keep you posted if I can figure out something.

Thanks

Thomas

0 Kudos
Dave_Mishchenko
Immortal
Immortal

What sort of values do you show for memory on the Resource Allocation tab. If the memory reservation is low, you can squeeze some more by modifying the VIM memory reservation (configuration \ system resource allocation).

0 Kudos
twooten
Contributor
Contributor

Hi Dave

I have attached a couple screenshots of one of the VMs. I don't have a reservation set for Memory or CPU.

On the ESXi server, there is a 299Mhz reservation set for the CPU and no reservation set for RAM.

Thanks

Thomas

0 Kudos
Dave_Mishchenko
Immortal
Immortal

Can you post a screen shot of the host's Resource Allocation tab?

0 Kudos
twooten
Contributor
Contributor

Here ya go bud...And I definitely appreciate your help!!! i can't make heads or tails out of it. Everything looks OK to me. But I'm still a newbie.

0 Kudos
Dave_Mishchenko
Immortal
Immortal

It's actually the resource allocation tab that I was looking for Smiley Happy - see attached image.

0 Kudos
KhanStPreest
Contributor
Contributor

Dave, appreciate your helping us. Here are some of my screenshots. The host resource allocation tab only ever shows 100 - 101MB memory reservation even though the summary screen shows considerably more than that available. I have never set that, not on purpose anyway, and cannot find a corresponding setting to change it.

Thanks, Khan

0 Kudos
twooten
Contributor
Contributor

OOPPSS!!!! Sorry about that Dave

Here ya go...

0 Kudos