VMware Cloud Community
a_f_rahim
Contributor
Contributor

virtual center 2.5 rc build and non-ssl connection ...

hello all!

i'm running 3 esx servers running esx 3.5 rc build and a windows (2k3 x86 r2) server running virtual center + client 2.5 rc build ... i'm planning to run some scripts that use the non-ssl (http) protocol to connect to the virtual center ... by default, virtual center only accepts only ssl connection but the non ssl port can be opened by editing the vpxd.cfg file ...

but in the rc build, the vpxd.cfg file is different than that of the previouds versions of vc 2.x ...

can anyone help me with this? how can i open the non-ssl ports in virtual center vin order to run my scripts ...

plz help ... i need to know this urgently ...

gift vouchers would be awarded as a complement ...

- ahmed Smiley Happy

0 Kudos
7 Replies
admin
Immortal
Immortal

You'll need to modify the proxy.xml file (same location as the vpxd.cfg file). Change the /sdk namespace to have httpAndHttps accessmode.

0 Kudos
a_f_rahim
Contributor
Contributor

thanks mate - but can give me some specific details on what to write?

i'm really new into virtualisation and do not have any basic idea on xml editing ... it would be really great if you could give me the specific lines to add ...

thank you once again Smiley Happy

0 Kudos
admin
Immortal
Immortal

I just use wordpad to edit files like this. In the block were serverNamespace is "/sdk", set the accessMode to httpAndHttps. You'll need to restart vpxd

0 Kudos
Porkopops
Enthusiast
Enthusiast

I'm having problems getting this sorted.. I'm on VC 2.5.

Is there an easy way to test the SDK connection over HTTPS or HTTP?

When using IE to test, whether I use httpsWithRedirect (default) or httpAndHttps, I get this:

> - This shows me the Virtual Center 2 Welcome page.

http://<server> - This simply gives me a totally blank IE page. No errors at all.

- Web page cannot be found

- Web page cannot be found

The VC Service is running. I'm restarting it after each change to the proxy.xml file. I did notice during tests, that the service can run without a proxy.xml at all.

To note: the following works OK -

Does the SDK have to be enabled somehow?

Thanks,

Paul

0 Kudos
Porkopops
Enthusiast
Enthusiast

All sorted.. The default HTTP port had been changed to 81..

works a trreat.

Paul

0 Kudos
citrvmw
Contributor
Contributor

Hi, {size:10pt}{color:#000000}I have installed XenDesktop 4 in one Windows Server 2003 when i start to configure , I was stopped in step to creat a Desktop Group me i chose in the hosting infrastructure VMware Virtualization i put our ip adresse of VMware so not working.after my serach i found i found i should the SDK directory, how do I create this and what should it contain also how can i enblae https in the esx {color}{size} {size:10pt}{color:#000000}if you have any idea for help i will be thankfull{color}{size} {size:10pt}{color:#000000}Many thanks{color}{size}
0 Kudos
ErgoBongo
Contributor
Contributor

0 Kudos