skyball
Contributor
Contributor

vcbMounter and failed snapshots

Hi,

I'm experiencing troubles with VCB and ESX 3.5.0 cluster accessing a NetApp FAS270 iSCSI SAN with software initiator.

I managed to backup several Linux VM (fullbackup), but sometimes the system is unable to perform the snapshot ("In progress" lasting forever and then timeouted - 15 mins ?). The cluster has available resources, bandwidth and plenty of free space on the SAN.

After that, I can't perform administrative tasks (power control, migration, ...) on the VM, as I always get a "Operation failed since another task is in progress" error.

If I restart the mgmt-vmware service on the ESX, it's OK and the VM is fully manageable again. I was able to perform manual snapshot in VC client without any problem, but VCB still failed. So I'd like to cure this, it might lead to troubles (DRS with VM unable to migrate ... no good)

What can this be due to ? I've read several posts about possible bugs in former versions of the products, which should have been fixed with latest updates, but I don't know which way to investigate or what to check.

iSCSI reservations ? System overload ? An update to wait for ? Some tuning (timeouts, ...) ?

I've made tries on my two clustered ESX after migrations, and it was the same. The VM is a strict copy of another one, which works and backups flawlessy.

I've tried using vcbMounter with normal and nbd modes, it works better (less failures) with the second one.

But I still don't unterstand what happens ...

Thanks for any help

0 Kudos
3 Replies
skyball
Contributor
Contributor

Hi,

I've found something quite interresting today : the snapshot doesn't even begin, letting the VM in a strange state it never leaves (supposed to be performing a snapshot, but not doing anything actually and you can't change any setting because of this) until I restart the "mgmt-vmware" service :

Task Created : haTask-720-vim.VirtualMachine.reconfigure-754

Invalid transition requested (VM_STATE_CREATE_SNAPSHOT -> VM_STATE_RECONFIGURING): Tasks running

Failed to start Reconfiguring: vim.fault.TaskInProgress

Task Completed : haTask-720-vim.VirtualMachine.reconfigure-754

Activation : Invoke done on

Throw vim.fault.TaskInProgress

Result:

(vim.fault.TaskInProgress) {

dynamicType = <unset>,

task = 'vim.Task:haTask-720-vim.VirtualMachine.createSnapshot-136',

msg = ""

}

I think it's due to VMTools unable to quiesce the filesystem when working with an unknown OS (Fedora Core 4 in my case, but I strangely managed to backup an old Debian), as I get this error :

hostd-9.log:[2008-02-19 10:46:39.106 'VmMisc' 3076445088 warning] Failed to find conversion from Fedora to type: vim.vm.GuestOsDescriptor.GuestOsIdentifier

hostd-9.log:[2008-02-19 10:52:16.341 'VmMisc' 99408816 warning] Failed to find the guest family for guestos: Fedora

If I try to change the VM settings to another OS type and version, it's the same (tried with and without reconfiguring the VM)

But when I tweaked the "/etc/redhat-release" in my VM to expose a fake name "Red Hat Enterprise Linux AS release 3 (Fake FC4)", it was OK !

A bit dumb, isn't it ?

0 Kudos
gentool
Contributor
Contributor

Excellent! I just tried this with an old Fedora which we needed to backup via VCB and it works like a charm. Thanks so much for saving us time!!!! (and doing our homework for us :smileyblush:)

0 Kudos
ffortier
Contributor
Contributor

It worked for me too! Thanks alot!

I hope that Vmware will put this OS in their GuestOs list cause this patch can bring alot of confusion...

0 Kudos