bert_cl
Contributor
Contributor

vcb - snapshot deletion failed error

Hello,

We have implemented vcb for the backup of our VI environment. Everything works fine, but we often get the error "snapshot deletion failed". The environment is a cluster of 9 blades in 2 enclosures, connected through fiber to an Netapp Metrocluster san.

vcb command:

vcbmounter -h hostname -u root -p xxx -a ipaddr:hostname -r path_to_output_folder -t fullvm -m san -L6

vcb logfile:

2007-09-22 20:14:24.603 'blocklist' 1472 info] authenticating user root

2007-09-22 20:14:24.822 'blocklist' 1472 info] logged in!

2007-09-22 20:14:26.791 'app' 1472 verbose] using mapdiskregion to fetch large block map:

2007-09-22 20:14:27.228 'app' 1472 verbose] ============begin failed method call dump============

2007-09-22 20:14:27.228 'app' 1472 verbose] invoking mapdiskregion ] on vim.host.diskmanager.lease:5258e226-ae63-0014-90a3-004c10a68c1a

2007-09-22 20:14:27.244 'app' 1472 verbose] arg mapstart: 1488977920

2007-09-22 20:14:27.244 'app' 1472 verbose] arg maplength: 2805989376

2007-09-22 20:14:27.244 'app' 1472 verbose] fault msg: "an error occurred while accessing a disk lease."

2007-09-22 20:14:27.244 'app' 1472 verbose] =============end failed method call dump=============

2007-09-22 20:14:27.291 'blocklist' 1472 error] generic block list error code.

2007-09-22 20:14:27.306 'vcbmounter' 1472 error] error: failed to open the disk: unspecified error

2007-09-22 20:14:27.306 'vcbmounter' 1472 error] an error occurred, cleaning up...

2007-09-22 20:14:40.167 'vcbmounter' 1472 warning] snapshot deletion failed. attempting to clean up snapshot database...

2007-09-22 20:14:40.182 'vcbmounter' 1472 info] scanning snapshot consolidate helper

2007-09-22 20:14:40.182 'vcbmounter' 1472 info] found match: /vmfs/volumes/4486c171-016bff37-21be-0016355deff0/hostname/hostname.vmx-snapshot-180

2007-09-22 20:14:42.245 'vcbmounter' 1472 verbose] shutting down vmdb service...

2007-09-22 20:14:42.245 'vcbmounter' 1472 verbose] unregistering callback...

2007-09-22 20:14:42.245 'vcbmounter' 1472 verbose] ...done

Once we get this error, we can delete the snapshot manually without any problems (VI client -> vm guest -> snapshot manager -> select "consolidate helper" snapshot and delete)

Anyone has a clue how to solve this error?

Thanks in advance,

Bert Cl

0 Kudos
13 Replies
MCosta-PT
Contributor
Contributor

Hi all.

Same error here.

Anyowne?

0 Kudos
outbacker
Enthusiast
Enthusiast

Anyone know what "MapDiskRegion" even does? I get 36 of those in the VC task window one after the other for a particular vcb backup job (which fails with bpstart_notify failed(73) eventually. So far this is only happening to one vm, though I've yet to get a good file level backup anywhere anyhow.

0 Kudos
bburdzel
Contributor
Contributor

We have hundreds of these "MapDiskRegion" tasks in VC during a file level VCB on one of our servers. Did you ever find out what this is?

0 Kudos
outbacker
Enthusiast
Enthusiast

I haven't figured it out. The backups are working, so I just let it be.

0 Kudos
Tom_Daytona
Contributor
Contributor

We ran into this error. It ended up being the VM that we were backing up had some network mapped drives that were disconnected. We removed them and then it successfully backed up.

We also had another VM that had a CD mounted which was causing the same error.

GL All.

0 Kudos
nkrick
Enthusiast
Enthusiast

Any updates? I installed VCB 1.1 to hopefully address other issues and now I am getting this mapdiskregion problem on a VM that previously never had problems. There are no cd's or floppies attached, and there are no mapped drives.

0 Kudos
rsissick
Contributor
Contributor

I dont think that it has anything to do with networked mapped drives or attached CDs. I am going to call VMware and find out what this is. I get it on some backups but not on others.

0 Kudos
nkrick
Enthusiast
Enthusiast

I should have posted my findings before now.

I was able to determine that the VM's with Map Disk Region messages were all VM's with other snapshots. If I delete the snapshot on the VM, the map disk region messages go away and everything works fine. It seemed that the older that snapshot was, the more Map Disk Region messages occured (which makes sense). So, once we got old snaphots (that really should have been cleaned up prior to this problem occuring), the Map Disk Regions would take too long which seemed to cause the overall snapshot process to fail.

0 Kudos
rsissick
Contributor
Contributor

Thanks that makes allot more sense. I will be sure to check if there are other snapshots present. I think you could even script something like that to check first. I don't like snapshipots hangong around for long periods of time.

Sent by Good Messaging (www.good.com)

0 Kudos
bburdzel
Contributor
Contributor

The newer vcb modules come with a vcb_cleanup.bat which removes existing snapshots. many of my customers schedule a daily run to keep their environemnt clean.

0 Kudos
nkrick
Enthusiast
Enthusiast

vcbcleanup.bat does not clean up non-VCB snapshots. The problem described in this thread is due to non-VCB snapshots, or at least in my case the snapshots were not from VCB.

To clean up old VCB snapshots, you can also make a change in the config.js file (sorry, don't have the exact line available right now) to tell it to clean up old VCB snaps if they are encountered.

0 Kudos
Saturnous
Enthusiast
Enthusiast

Its the Parameter PREEXISTING_VCB_SNAPSHOT in config.js ("C:\Program Files\VMware\VMware Consolidated Backup Framework" which need to set to "delete" instead of "fail"

0 Kudos
kabeer
Contributor
Contributor

I had restart the VCB server and run the command with Virtual center credentials to unmount the snapshots. It works. I think there was a communication error between the VCB and VC. CMD is

eg: vcbmounter -h 10.1.1.1 -u "administrator" -p "P@ssw0rd" -U d:/mnt/servername

Regards,

Kabeer Siddiqui

0 Kudos