Bart_VK
Enthusiast
Enthusiast

time synchronization ESX server with Windows server 2003 time server

Hi,

Currently I configured my ESX servers to synchronize their time with my time server a Windows 2003 server which is not a DC. This server is onely used as time server. When I launch my ESX servers or restart the ntpd service ESX gives a status failed on synchronizing time with time server. The stopping and starting of the ntpd service gives an OK status. However when I use watch "ntpq -d" the ESX server is properly synchronized with my time server. Does anyone have an idea what the cause is of this issue ?

The NTP configuration of the ESX servers is as follows:

/etc/ntp.conf:

restrict 127.0.0.1

restrict default kod nomodify notrap

server srvmgt01.pierre.be

server srvmgt02.pierre.be

driftfile /var/lib/ntp/drift

/etc/ntp/step-tickers

srvmgt01.pierre.be

srvmgt02.pierre.be

/etc/hosts:

89.147.168.11 srvmgt01.pierre.be

89.147.168.12 srvmgt02.pierre.be

The NTP configuration on the Windows servers srvmgt01.pierre.be and srvmgt02.pierre.be is as follows:

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W32time/Parameters/Type REG_SZ NTP

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W32time/ParametersNtpServer REG_SZ time.belnet.be,0x1

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W32time/config/announceflags DWORD 5

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W32time/timeproviders/ntpserver/enabled DWORD 1

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/W32time/TimeProviders\Ntpclient/SpecialPollInterval DWORD 900

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config\MaxPosPhaseCorrection DWORD 1800

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config\MaxNegPhaseCorrection DWORD 900

0 Kudos
3 Replies
Berniebgf
Enthusiast
Enthusiast

Hi,

Cant answer you question directly however I have always had issue's in getting the NTP right....now I just use the following script to set it up..

see if this helps.

http://www.vmcolonel.net/?p=13

Hope it helps

best regards

Bernard

0 Kudos
Rajeev_S
Expert
Expert

Brat

: Make sure that the ntpclient is allowed in esx firewall .

0 Kudos
Bart_VK
Enthusiast
Enthusiast

Rajeev,

My ntpclient is enabled in the ESX firewall.

Kind regards

0 Kudos