HannesJ
Contributor
Contributor

ntpd-daemon isn't running after a esx-server reboot.

Hello all

I have disabled the esx-firewall with the command "chkconfig firewall off" (manipulation the system-runlevels). Then I configured the ntpd-daemon with "chkconfig --level 345 ntpd on". When I reboot our esx-servers (3.0.1), then the ntpd will not start in any runlevels. The "chkconfig"-command will give me the following output:

\[root@server1 /]# chkconfig --list ntpd

ntpd 0:off 1:off 2:off 3:off 4:off 5:off 6:off

Why does the "ntpd" always be disabled after a reboot?

Thanks a lot.

HannesJ

0 Kudos
6 Replies
cheeko
Expert
Expert

when you do "chkconfig --level 345 ntpd on" and right after that "chkconfig --list ntpd" you should get "ntpd 0:off 1:off 2:off 3:[b]on[/b] 4:[b]on[/b] 5:[b]on[/b] 6:off"

can you verify that behaviour?

0 Kudos
wobbly1
Expert
Expert

use the VI client or VC to change the firewall settings or esxcfg-firewall at the command line rather than the native linux tools in the service console

for info, I just tried what you have done and get the same behaviour - chkconfig --list after setting ntpd on for levels 345 shows on but a reboot results in reset to off

Message was edited by:

wobbly1

0 Kudos
cheeko
Expert
Expert

Unfortunately, there is no way to configure NTP through VI Client.

http://kb.vmware.com/KanisaPlatform/Publishing/408/1339_f.SAL_Public.html

0 Kudos
HannesJ
Contributor
Contributor

When I enter "chkconfig --level 345 ntpd on" an then "chkconfig --list ntpd", I receive the correct return:

\[root@server1 /]# chkconfig --list ntpd

ntpd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

But after a reboot, the settings will be overwritten, so the ntpd-daemon will not start.

Thanks a lot.

HannesJ

0 Kudos
jlanders
VMware Employee
VMware Employee

You manually enabled the NTP daemon using the Unix

command line tools on the service console and disabled

the firewall. This will work, but unless the VC host agent

gets informed, these changes won't be persistent.

On ESX 3.0.1, a better way to enable NTP is to use VC.

On the ESX "Configuration" page, select "Security Profile"

on the left hand side, then "Properties" in the upper

right hand corner of the page. Tick the NTP entry in the

"Services" dialog. You'll probably first have to re-enable

the firewall in the Service Console to get the changes to

stick.

If you want, you can then use 'chkconfig' to disable the

firewall again. I'm not sure why you'd want to, but that's

up to you.

As another member indicated, you'll still need to configure

the NTP daemon manually. I'm assured that this capability

will be in a future version of VC.

Joe

0 Kudos
HannesJ
Contributor
Contributor

With enabling the NTPD in the VC, it works.

Thanks a lot.

HannesJ

0 Kudos