Michael_Michae1
Contributor
Contributor

no useful running ifconfig vmnic1 down

I see no "UP" in the output of "ifconfig vmnic1 " after running "ifconfig vmnic1 down" . However , from vmware side , vmnic1 is not "down" via "./esxcfg-nics -l ". it's useful to disable/enable these nic ports during networking troubleshooting . which way can I disable vmnic ?

Tags (2)
0 Kudos
7 Replies
AndreTheGiant
Immortal
Immortal

What's the output of?

ethtool vmnic1

Is your NIC controller in HCL? And is enable also in BIOS?

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
Michael_Michae1
Contributor
Contributor

problem is , for any ports , set a example of vmnic1 , the output ./esxcfg-nics -l till showes vmnic1 "UP" though i have run the command of "ifconfig vmnic01 down". so how to make nic port "DOWN" using linux or vmware command line ?

BR

it is in hcl HW support list .

# ethtool vmnic1

Settings for vmnic1:

Supported ports:

Supported link modes: 10baseT/Half 10baseT/Full

100baseT/Half 100baseT/Full

1000baseT/Full

Supports auto-negotiation: Yes

Advertised link modes: 10baseT/Half 10baseT/Full

100baseT/Half 100baseT/Full

1000baseT/Full

Advertised auto-negotiation: Yes

Speed: 1000Mb/s

Duplex: Full

Port: Twisted Pair

PHYAD: 1

Transceiver: internal

Auto-negotiation: on

Supports Wake-on: g

Wake-on: g

Cannot get message level: Function not implemented

Link detected: yes

#

0 Kudos
AndreTheGiant
Immortal
Immortal

which way can I disable vmnic ?

I'm not sure that there is a command to disable a single nic.

In this case I simple remove the nic from the vSwitch.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
avlieshout
VMware Employee
VMware Employee

Move the adapter from active to unused in the NIC teaming properties of the vSwitch. That way the vmnic is not used by the vSwitch anymore.

Alternatively you could remove the vmnic from the vSwitch.

-Arnim van Lieshout

-


Blogging: http://www.van-lieshout.com

Twitter:

If you find this information useful, please award points for "correct" or "helpful".

Arnim van Lieshout Blogging: http://www.van-lieshout.com Twitter: http://www.twitter.com/avlieshout If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
adamiano
Contributor
Contributor

There is no way?

Rumple
Virtuoso
Virtuoso

your standard linux ifconfig in the service console is not going to do anything to a vmnic as thats under the control of the vmkernel. If there is anything is will be in the esxcfg commands (or other vmware specific commands).

Michael_Michae1
Contributor
Contributor

vmware services take over almost all network control so that it's no use stopping network service neither . The only way , as far af i know for 3.5 ,is to shutdown the Vm esx host .

0 Kudos