IgorZ
Contributor
Contributor

iSCSI storage disconnected

Jump to solution

For some odd reason my ESX3.5 server lost its connection to our iSCSI storage, i.e. when I go to the configuration tab and look at storage I no longer see the lun and the inventory shows the VMs that are on the iSCSI lun as "Unknown (inaccessible)". This is a stand-alone server, the only one that was connected to the lun, and I'm not using virtualcenter.

Is there a way to remount the lun without reformatting it and losing all the data on it?

0 Kudos
1 Solution

Accepted Solutions
mike_laspina
Champion
Champion

Then there could very well be a failure at the target, hopefully recoverable.

http://blog.laspina.ca/ vExpert 2009

View solution in original post

0 Kudos
8 Replies
JRink
Enthusiast
Enthusiast

Did you lose connection after a reboot of ESX or just suddenly for no apparent reason? Might help to diagnose the problem.

I had this happen after a reboot once, and it was a result of having another ESX host connected to the same LUN on a storage SAN. I'd also check if you are having potential network issues in the assumption that you have your iSCSI SAN on a seperate VLAN used by ESX?

Furthermore, you can always recreate the whole iSCSI config on ESX and try again. You WON'T lose any of your VMs on the SAN device by just removing the configuration from ESX and re-adding the virtual switch, VMkernel, 2nd service console, etc.

JR

0 Kudos
IgorZ
Contributor
Contributor

It was lost after a reboot; I was having problems with some VMs and rebooted the box. When it came up, it no longer showed the lun with the VMs.

I'm not sure what you mean by "recreate the whole iSCSI config on ESX and try again." If I go to Add Storage on the VI client and try to add the lun with the VMs on it, esx wants to format the lun. I was thinking there might be a way to do this behind the scenes somehow on the console by editing config files if possible.

0 Kudos
mike_laspina
Champion
Champion

Hello,

Thats not a good sign.

Is your iSCSI config is defined as before and the LUN shows up and the volume is not detected and the LUN appears to be unformatted?

Make sure you rescan the adaptors twice.

This is more likely a target issue. Your initiator is up and running.

iSCSI is like a virtual cable. So what is it connected to should be the next area to explore.

What are you running for a target?

http://blog.laspina.ca/ vExpert 2009
0 Kudos
IgorZ
Contributor
Contributor

Nothing changed in the configuration. I still see the same iSCSI initiator and it's still shows that it's pointing to the same target.

0 Kudos
mike_laspina
Champion
Champion

Then there could very well be a failure at the target, hopefully recoverable.

http://blog.laspina.ca/ vExpert 2009
0 Kudos
JRink
Enthusiast
Enthusiast

Regardless of whether your LUNs are screwed up, IF you still have connectivity to the SAN via iSCSI, you should see this under the Host Server "Storage Adapters" section in VI client. It should show your iSCSI target and display "Targets: 1" even if it doesn't see any valid LUNs. What is listed on that screen? This should tell you at least whether you are having iSCSI connection problems or just a specific LUN problem... (I think).

See this screenshot for example..

JR

JRink
Enthusiast
Enthusiast

I take back my statement of, "It should show yoru iSCSI target and display "Targets: 1" even if it doesn't see any valid LUNs." I tested this a moment ago to be removing the iSCSI initiator associated with the LUN on my testing development esx box, re-scanned, and it said Targets: 0 when there were no LUNs.

Can you create a new "test" LUN on your SAN and see if you can connect to that properly? That would at least verify if you have connectivity and your iSCSI settings on your host are correct.

JR

0 Kudos
IgorZ
Contributor
Contributor

Crisis averted! Something happened on the target device. All it took was a forced reboot of the target, after the target device came back up I rebooted the ESX box and it once again showed that the iSCSI LUN was mounted.

Thanks to everyone who helped

0 Kudos