JRink
Enthusiast
Enthusiast

help copying .flp file with winscp

Jump to solution

Not sure what I'm doing wrong.

I am trying to use WinSCP to copy a .FLP file (so I can load the LSI drivers on an XP VM) to my ESX server. When I copy the file, the filename gets renamed to vmscsi-1.2.0.4.flp.filpart and it won't rename it back to vmscsi-1.2.0.4.flp.

Winscp reports the following:

"Transfer was successfully finished, but tempoary transfer file 'vmscsi-1.2.0.4.flp.filepart' could not be renamed to target file name 'vmscsi-1.2.0.4.flp'. If this problem persists, you may try to turn off transfer resume support.

Permission denied.

Error code: 3

Error message from server: Permission denied

Request code: 18

What's odd, is when I copy another file , for example, pic.jpg, I don't receieve this same error using WinSCP and copying into the same destination directory.

Thougths?

edt: I should mention I am trying to copy this file to my datastore "Storage2", and have also tried copying to datastore "Storage1"

0 Kudos
1 Solution

Accepted Solutions
RParker
Immortal
Immortal

Try copying the file to the \tmp folder, then using the ESX console move it (mv vmscsi-1.2.0.4.flp /vmfs/volumes/storage2/). See if that works.

View solution in original post

0 Kudos
6 Replies
RParker
Immortal
Immortal

Try copying the file to the \tmp folder, then using the ESX console move it (mv vmscsi-1.2.0.4.flp /vmfs/volumes/storage2/). See if that works.

View solution in original post

0 Kudos
Troy_Clavell
Immortal
Immortal

when building a vm and OS install asks you to hit f6, I usually just mount the .flp file using the virtual floppy option in the VM. I don't think it's necessary to copy it to the ESX server, just copy it to a network resource.

0 Kudos
dandeane
Enthusiast
Enthusiast

Try using Fast Veeam, it allows you to su to root when logging in where as winscp does not. Once su'd to root you should be able to copy the file directly into the vmfs volumes or the vmimages folder.

JRink
Enthusiast
Enthusiast

Is it best practice to copy files to the /tmp folder when using WinSCP?

This trick worked. Thanks, I wouldn't have thought of that.

0 Kudos
Dave_Mishchenko
Immortal
Immortal

You should be able to get around that by selecting SCP as the protocol when you start WinSCP (rather than SFTP with SCP fallback). Or you can disable the resume feature in WinSCP.

0 Kudos
boy
Contributor
Contributor

Stopping WinSCP filepart errors

http://www.rtfm-ed.co.uk/?p=445

0 Kudos