dlee_12
Contributor
Contributor

hi! i'm evaluating the new esx3. 5 server in a test environment and i would like to copy out the VMs from the VDM server (VDI2.0) using winscp. How do i enable ftp to work in this case? security is not an issue as this is an testing environment. Please provide me the steps on how tis can be done. i'm new to linux as well. Smiley Happy Thanks.

0 Kudos
1 Solution

Accepted Solutions
kjb007
Immortal
Immortal

To sftp/scp files out from the ESX host, you'll need to open the firewall port, you can either go to the esx configuration section of the esx host from the vi client, go to security profile, edit the properties and enable the sshClient. Or, go to the service console, and run 'esxcfg-firewall --enableService sshClient'

If you want to be able to sftp/scp into the esx server, you will need to allow root access. Edit the /etc/ssh/sshd_config file, and change the PermitRootLogon to yes, and restart sshd.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB

View solution in original post

0 Kudos
3 Replies
kjb007
Immortal
Immortal

There is no ftp daemon by default on ESX. You can install, but that is not recommended, and doubly not recommended since you are new to Linux. You'll need to use sftp or scp to go through ssh. winscp would be almost as fast as ftp. Any reason you want ftp here?

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
0 Kudos
dlee_12
Contributor
Contributor

hi! that's ok(sftp or scp ) as well as long as i can transfer the vm files out.......how do i enable that? Thanks.

0 Kudos
kjb007
Immortal
Immortal

To sftp/scp files out from the ESX host, you'll need to open the firewall port, you can either go to the esx configuration section of the esx host from the vi client, go to security profile, edit the properties and enable the sshClient. Or, go to the service console, and run 'esxcfg-firewall --enableService sshClient'

If you want to be able to sftp/scp into the esx server, you will need to allow root access. Edit the /etc/ssh/sshd_config file, and change the PermitRootLogon to yes, and restart sshd.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB

View solution in original post

0 Kudos