admin
Immortal
Immortal

duplex settings

Jump to solution

Folks, I am trying to set the speed and duplex settings of my ESX 3.5.

However, after I changed the speed using ethtool, the network link goes down and now I am not able to bring it back.

I tried the running the following commands

ethtool -s vmnic0 speed 1000 duplex full

How do i change the speed duplex setting for the Service Console of ESX 3.5?

Thanks

0 Kudos
1 Solution

Accepted Solutions
Texiwill
Leadership
Leadership

Hello,

ethtool is provided however it really should not be used. You should instead use esxcfg-nics.

esxcfg-nics -s 1000 -d full vmnic0


Best regards,

Edward L. Haletky

VMware Communities User Moderator

====

Author of the book 'VMWare ESX Server in the Enterprise: Planning and Securing Virtualization Servers', Copyright 2008 Pearson Education. CIO Virtualization Blog: http://www.cio.com/blog/index/topic/168354, As well as the Virtualization Wiki at http://www.astroarch.com/wiki/index.php/Virtualization

--
Edward L. Haletky
vExpert XIV: 2009-2022,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill

View solution in original post

0 Kudos
2 Replies
Texiwill
Leadership
Leadership

Hello,

ethtool is provided however it really should not be used. You should instead use esxcfg-nics.

esxcfg-nics -s 1000 -d full vmnic0


Best regards,

Edward L. Haletky

VMware Communities User Moderator

====

Author of the book 'VMWare ESX Server in the Enterprise: Planning and Securing Virtualization Servers', Copyright 2008 Pearson Education. CIO Virtualization Blog: http://www.cio.com/blog/index/topic/168354, As well as the Virtualization Wiki at http://www.astroarch.com/wiki/index.php/Virtualization

--
Edward L. Haletky
vExpert XIV: 2009-2022,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos