VMware Cloud Community
vmcms
Contributor
Contributor
Jump to solution

Windows Server 2008 RC0 no network adapter detected.

I've installed Windows Server 2008 RC0 on an ESX 3 server. No network adapter is detected.

Has anyone else done a 2008 install on ESX? Any suggestions for installing a driver?

Reply
0 Kudos
1 Solution

Accepted Solutions
Dave_Mishchenko
Immortal
Immortal
Jump to solution

Have you installed VMware tools yet? You would also could also edit the VMX for the file and set the NIC to emulate an Intel Pro/1000 card with the below.

ethernet0.virtualDev = "e1000"

View solution in original post

Reply
0 Kudos
8 Replies
Dave_Mishchenko
Immortal
Immortal
Jump to solution

Have you installed VMware tools yet? You would also could also edit the VMX for the file and set the NIC to emulate an Intel Pro/1000 card with the below.

ethernet0.virtualDev = "e1000"

Reply
0 Kudos
Jim_VM
Contributor
Contributor
Jump to solution

Could someone please post your entire .vmx file that you have actually working flawlessly for you (as opposed to "should work"). Some of us Windows-centric geeks are really struggling with this. It would be greatly appreciated.

Reply
0 Kudos
esiebert7625
Immortal
Immortal
Jump to solution

When I first installed 2008 RC0 the network adapter did not have a driver for it. After I installed VMware Tools and set a IPv4 IP address it worked just fine for me.

Here's my vmx file:

#!/usr/bin/vmware

config.version = "8"

virtualHW.version = "4"

floppy0.present = "false"

nvram = "Win2008-RC0.nvram"

powerType.powerOff = "default"

powerType.powerOn = "default"

powerType.suspend = "default"

powerType.reset = "default"

displayName = "Win2008-RC0"

extendedConfigFile = "Win2008-RC0.vmxf"

scsi0.present = "true"

scsi0.sharedBus = "none"

scsi0.virtualDev = "lsilogic"

memsize = "1024"

scsi0:0.present = "true"

scsi0:0.fileName = "Win2008-RC0.vmdk"

scsi0:0.deviceType = "scsi-hardDisk"

ide0:0.present = "true"

ide0:0.clientDevice = "FALSE"

ide0:0.deviceType = "cdrom-image"

ide0:0.startConnected = "TRUE"

floppy0.startConnected = "false"

floppy0.clientDevice = "true"

ethernet0.present = "true"

ethernet0.allowGuestConnectionControl = "false"

ethernet0.networkName = "VM Network VLAN3"

ethernet0.addressType = "vpx"

ethernet0.generatedAddress = "00:50:56:bf:3c:4b"

guestOS = "winnetstandard"

uuid.bios = "50 3f 53 e5 da ec ee ee-5e e7 cf 62 8c 17 4a 10"

toolScripts.afterPowerOn = "true"

toolScripts.afterResume = "true"

toolScripts.beforeSuspend = "true"

toolScripts.beforePowerOff = "true"

ide0:0.fileName = "/vmfs/volumes/67d8f808-f46509b9/6001.16659.070916-1443_x86fre_Server_en-us-KR1SFRE_EN_DVD.iso"

scsi0:0.redo = ""

uuid.location = "56 4d 9d fb dd 39 84 10-89 1f ce 32 d6 d7 7e a0"

sched.swap.derivedName = "/vmfs/volumes/4404e8b4-bcfd52fc-1e4b-0017a4a91076/Win2008-RC0/Win2008-RC0-d5405ba8.vswp"

tools.syncTime = "FALSE"

-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

Thanks, Eric

Visit my website:

-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

ITThies
Hot Shot
Hot Shot
Jump to solution

What are your experiences about Windows Server 2008 (performance / stability) in VMware?

----- Please feel free so give some points for a correct / helpful answer! Thank you!
Reply
0 Kudos
esiebert7625
Immortal
Immortal
Jump to solution

I have not had a chance to play with it that much but from what I've seen it's been stable and performs well.

-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

Thanks, Eric

Visit my website:

-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-=-=-=-=-=-=-=-

Ian_T
Contributor
Contributor
Jump to solution

I have the same problem, but I also can't install the VMWare tools.. I get the error "A general system error occured:Internal error".. anybody else seen that one?

Reply
0 Kudos
Brock
Contributor
Contributor
Jump to solution

Setting the NIC to Intel in the vmx file did the trick for me on RC1!

Reply
0 Kudos
IT16
Contributor
Contributor
Jump to solution

Hey,

I was reading your post from November 07 regarding installing vmware tools on a Windows 2008 server VM. Did you ever figure that out?

Thanks,

Keith, IT at SolarCity

Reply
0 Kudos