MattCarey
Contributor
Contributor

Web site hosting the update signatures and update packages can not be reached

I am getting the error that is in the subject line from the update manager after upgrading to VC 2.5.

This is in our QA lab which is firewalled off, but I have setup an exception for the Virtual Center server to be able to have outgoing web access on port 80.

Is there any other exception I'll need to setup to get these signatures downloaded? I'd like to make sure this works in our lab before updating production Smiley Happy

0 Kudos
16 Replies
VirtualKenneth
Virtuoso
Virtuoso

Getting the same error in an environment where a proxy server is used.

Strange thing is that, when using a proxyserver, you have to manual edit the proxy settings (afaik) by use of the vum-proxyAuthCfg.exe

I enter the proxyserver name which doesn't need any authentication, but the program keeps asking me for a "Proxy Password" since this is mandatory

0 Kudos
mats82
Contributor
Contributor

i am having the same issues.

I have opened all outgoing ports for internet access and run the proxy config tool but still get the same error message:

"Web site hosting the update signatures and update packages cannot be reached"

Any more ideas to try?

0 Kudos
robert_landes
Contributor
Contributor

VMware Update Manager is using windows based http functionality. If you are running Windows Server 2003 (incl. R2) try to uninstall the "Internet Explorer Enhanced Security Configuration" via "Add/Remove Windows Components".

/Rob

0 Kudos
Smeagol
Enthusiast
Enthusiast

No enhance security here and still have the same issue as well.

Access is direct no firewalls etc. I can access vmware directly from the vc server.

Stumped Smiley Sad

0 Kudos
RickPollock
Enthusiast
Enthusiast

Do you use a proxy? If so you will have to set this for update manager to contact the Shavlik site. You can either run the vum-proxyAuthCfg.exe or directly modify the vci-integrity.xml file in your update manager installation directory.

<proxySettings>

<useProxyServer>false</useProxyServer> <!-- true -->

<proxyServer></proxyServer> <!-- proxy.vmware.com -->

<proxyPort></proxyPort> <!-- 3128 -->

</proxySettings>

0 Kudos
ISL
Contributor
Contributor

I am having the same problem. Am able to navigate to www.shavlik.com direct from the server. I've removed the IE Security stuff, have configured the proxy settings in the xml file and have opened up the necessary holes in our firewall, but still get the same problem - any ideas?

Cheers,

TK

0 Kudos
VirtualKenneth
Virtuoso
Virtuoso

What does the logging tell you?

0 Kudos
ncarde
Enthusiast
Enthusiast

I'm getting a similar error -- here is what my 'vmware-vci-log4cpp.log' indicates:

Error 12015 from WinHttpSendRequest for url

Download host update metadata error, Error 12015 from WinHttpSendRequest for url

Waiting for 16 seconds to retry.

I have removed the Internet Explorer Enhanced Security to no avail.

0 Kudos
MWPatterson
Contributor
Contributor

I was having the problem, I also had my VC Box dual honed as we have an isolated network for management and after I removed the gateway from my private IP Add it is working. Not sure if this helps but, my 2 cents.

0 Kudos
cxnexo
Contributor
Contributor

Using vum-proxyAuthCfg.exe was not the solution for me, because we are not using a proxy with authentication. Instead, I've edited the following file: vci-integrity.xml and added my proxy settings under the <proxySettings>

Stopped and restarted the service and it worked.

0 Kudos
mbkins71
Contributor
Contributor

Here is what I did to finally get it to work:

I edited the vci-integrity file and changed everything to use port 80 instead of 443. I also changed the path to instead of using https. I then restarted the VUM service and it worked just fine. I am glad to have finally gotten this to work.

0 Kudos
EE99
Contributor
Contributor

Thanks, change to port 80 and http worked for me to .

0 Kudos
Jeff1981
Enthusiast
Enthusiast

Something the Administration Guide neglects to tell you ,when editing the vci-integrity.xml file, be sure to set "useProxyServer" to "true"

Example:

Original:

<proxySettings>

<useProxyServer>false</useProxyServer> <!-- true -->

<proxyServer></proxyServer> <!-- proxy.vmware.com -->

<proxyPort></proxyPort> <!-- 3128 -->

</proxySettings>

New:

<proxySettings>

<useProxyServer>true</useProxyServer> <!-- true -->

<proxyServer>127.0.0.1</proxyServer> <!-- proxy.vmware.com -->

<proxyPort>8123</proxyPort> <!-- 3128 -->

</proxySettings>

0 Kudos
patrickkaegi
Contributor
Contributor

hi vmware hackers Smiley Wink

I have exactly the same error but i just try to import the updates from a local directory. Does anybody have the same problem or even better a solution for the problem?

thanks for any hint

Patrick

0 Kudos
vmwaredimetroni
Contributor
Contributor

hi guys!

i had found the same problem in our infraestructure,

i checked some parameters in our firewall and problem was located in

rule https, i think that before updates were receiving by http but now

is https.

we create new rule in firewall with https profile and now we can update again our servers.

i hope that this information was helpful.

0 Kudos
zippy_thewonder
Contributor
Contributor

We had the same thing. We have an ISA2006 Proxy

Firstly, after running vum-proxyAuthCfg.exe and supplying proxy credentials, I was still getting the same error. However, after editing the vci-integrity.xml, and specifiying the following:

<userProxyServer>true</userProxyServer>

<proxyServer>proxy.internal.blah</proxyServer>

<proxyPort>8080</proxyPort>

And then restarted the VMware Update Manager service, and then all worked fine. Hope this helps!

0 Kudos