VMware Cloud Community
Banja_Lord
Contributor
Contributor

Vmotion between DL 585 and DL585 G2

How can I know before I buy my DL585 G2 that I can vmotion between the 2 server on ESX 3.01??

Reply
0 Kudos
10 Replies
MartijnLo
Enthusiast
Enthusiast

This is the KB article concerning Vmotion compatibility.

http://kb.vmware.com/vmtnkb/search.do?cmd=displayKC&docType=kc&externalId=1992&sliceId=SAL_Public

DL585 G2's use the Opteron with 8000 designators so they'll probably fall into group D. The previous generation that we have are 8xx Opteron so that will probably be Group C.

I think I have read somewhere in these forums that applying the "mask" that is mentioned in the KB article means permanently disabling the feature you mask but maybe someone can elaborate on that.

Reply
0 Kudos
dougjef
Enthusiast
Enthusiast

Just want to give my first hand account. I can successfully vmotion between a DL585 with 2.4GHZ Opteron 880's and DL385 2.2GHZ Opteron 275's to a new DL585G2 with the 2.6GHZ 8218 chips just fine without issue despite what the documents say....

Reply
0 Kudos
JonT
Enthusiast
Enthusiast

That's interesting because I tried the same test from a DL585 w/ 2.2Ghz Opterons to a 585 G2 w/ 2.6Ghz and actually got an error when trying to VMotion, the Validation wouldn't even succeed. I didn't waste too much time on it though because I have plenty of G1's laying around.

Reply
0 Kudos
Ralf-B
Contributor
Contributor

@johnT

what is happening after the validation ist succeed ?? do you get "operating timed out"

Reply
0 Kudos
dougjef
Enthusiast
Enthusiast

By the way I'm running 3.0.1 with VC 2.01 patch 2. Not showing any custom entries in the AMD Override tab of the VM either.. Validation is successful on vmotion although I did get a validation warning message on the Dmotion (from 2.5-3.0 but it let me continue and was successful. After that wiped the DL585 G1's and loaded 3.0.1 fresh and vmotions between the G1's and G2's are working great.

That HP FTP site is still showing the G1's in group 1 and the G2's in group 2 so its not supposed to work according to HP. Just wanted to let people know its working in my environment no issues between 8 different servers all on 3.0.1 with about 120vm's.

I wasn't looking forward to not being able to vmotion between these since it was a significant investment and wanted to be able to have all vm's be available on all hosts. Luckily it works!

Reply
0 Kudos
ErMaC1
Expert
Expert

You should only see an issue with vMotioning 64bit VMs. Do you only run 32bit virtual machines?

Reply
0 Kudos
dougjef
Enthusiast
Enthusiast

ErMaC, you are right. I am only running 32bit vm's but did test x64 this morning and got the error message.

So, basically the x64 machines will not vmotion at all between the 585g1 and g2 even with a mask applied based on VMware article 1992 correct?

I'm fine with that for now, but in the future it's nice to know. Thanks!

Reply
0 Kudos
ErMaC1
Expert
Expert

Correct, 64-bit VMs will not Vmotion between the two at all.

Reply
0 Kudos
markzz
Enthusiast
Enthusiast

Sorry guys and gals, I'm aware this is a very old thread and but I'm trying to resurect it. I have some answers and a couple of questions.

We are in precisely the position described by this thread. "Vmotion between DL-585 and DL-585 g2".

I've used the CPU masking routine descibed in the below articles

Modifying the masks

Intel CPU Compatability from VMware

AMD CPU Compatability from VMware

This has worked a treat although as we are using ESX3.5 with VC2.5 the implementation of having to apply the CPU mask per Guest is quite an arduouis process.

The mask I've used is:-

*************************

AMD Override Masking 32bit OS

*************************

Combined 80000001 ecx -


-


-


-


-


-0 -


0-

Combined 80000001 edx with hideNX Flag -


0-0- ---0 -


-


-


-


-


Now the 64bit question.

I've read here in this thread that you can't VMotion between the DL585 and DL585g2 with a 64 bit OS, I'm just not clear on why it's not possible. Surely it's just a case of using an appropriate CPU mask.?

I was going to log a call with VMware on this but figured the forum is a better place to start.

Any advice would be greatly appreciated.

Reply
0 Kudos