VMware Cloud Community
Andrew_Judge
Contributor
Contributor

Vmotion and AMD 270 and 2218 Procs

Been trying to ge them to play nicely by masking the registers, but can't seem to. Anyone had luck with this? - They are DL360 G1 and G2. In VC I get:

CPUID level 0x80000001 register 'ecx'

host bits: 0000:0000:0000:0000:0000:0000:0000:0010

required: 0000:0000:0000:0000:0000:000x:000x:xxx1

On one server, I have:

pcpu 00 01 02 03

family 15 15 15 15

model 01 01 01 01

type 00 00 00 00

stepping 02 02 02 02

tscKhz 2600091 2600091 2600091 2600091

processorKhz 2600091 2600091 2600091 2600091

busKhz 200007 200007 200007 200007

name AuthenticAMD AuthenticAMD AuthenticAMD AuthenticAMD

ebx 0x00020800 0x01020800 0x02020800 0x03020800

ecxFeat 0x00002001 0x00002001 0x00002001 0x00002001

edxFeat 0x178bfbff 0x178bfbff 0x178bfbff 0x178bfbff

initApic 0x00000000 0x00000001 0x00000002 0x00000003

apicID 0x00000000 0x00000001 0x00000002 0x00000003

On the other I get

pcpu 00 01 02 03

family 15 15 15 15

model 01 01 01 01

type 00 00 00 00

stepping 02 02 02 02

cpuKhz 2004545 2004545 2004545 2004545

busKhz 200454 200454 200454 200454

name AuthenticAMD AuthenticAMD AuthenticAMD AuthenticAMD

ebx 0x00020800 0x01020800 0x02020800 0x03020800

ecxFeat 0x00000001 0x00000001 0x00000001 0x00000001

edxFeat 0x178bfbff 0x178bfbff 0x178bfbff 0x178bfbff

initApic 0x00000000 0x00000001 0x00000002 0x00000003

apicID 0x00000000 0x00000001 0x00000002 0x00000003

So... ecx is off and I've tried masking:

ecx 80000001

-


0- -


0- -


0- -


0-

Can't get it...

Reply
0 Kudos
0 Replies