rlindell
Contributor
Contributor

VMtools showing out of date after upgrade

I have upgraded to ESX 3.5 and I am still showing that VMtools is still out of date even after I upgaded the tools. Anybody know a fix?

Thanks

0 Kudos
4 Replies
RParker
Immortal
Immortal

Sometimes the error is erroneous, did you restart the guest after you installed the tools?

If it's windows, you can right click the icon, and open VM tools, click about to see the build. The latest build of the tools is the same as the ESX server build

Then it could be that the VC doesn't have the most up to date, you may have to restart the VC or click F5/Refresh to verify that the tools status has been updated.

0 Kudos
dawho9
Enthusiast
Enthusiast

I'm having the same problem on my Windows hosts. I have confirmed the version from the VM tools as being correct - the VIC simply misreports them. I have restarted the VM, the VC Server and it remains.

Its only a cosmetic error but irritating because its difficult to know which one's I've updated.

Richard

0 Kudos
RParker
Immortal
Immortal

Sometimes you need to poweroff the VM, then power on, instead of reboot. Once the console sees the VM is "off" it resets the screen, then when it comes up, its fine. but you need to make sure the VM Tools actually installed properly (by right clicking properties and verify the actual tools version is correct).

Sometimes you have to uninstall the tools, reboot, install the tools, power off, power on, then everything is good.

0 Kudos
Engelsman
Enthusiast
Enthusiast

Restarting the VMware Tools service sometimes helps as well.

Or restarting the mgmt-vmware service on the ESX host

Regards

0 Kudos