tachikoma66
Contributor
Contributor

VI Timeout's and Network Gremlins

My Console port's are on another VLAN and switch other than my DC which holds the license server and virtual center. Whenever I am logged into the VI my hosts will have issues timing out randomly doing basic actions (like deploying a template, deleting files from local storage)

Sometimes it will work, sometimes it just sits there. Other times I notice the Host graying out in the listing.

I spent awhile with the vmware technical support and they verified my install was good and the esx side of things is configured correctly. I assume its a networking issue, with all the VLAN's and mixed network gear.

The ESX Hosts have no issues when it comes to the VM's themselves, this is just a console port issue. I'll post my whole config and maybe there might be some other ideas and suggestions.

1 Cisco 5510 (aka 5510)

2 Cisco 48 port gigabit 3750 switches (aka 3750A, 3750B)

1 HP pro curve 48 port gigabit switch (ManagementSwitch)

4 HP DL360's with 2 Quad port nics (aka ESX Hosts)

1 HP DL360 for baremetal DC with 2 mb nic ports (aka DC)

Each ESX host is configured:

- MB nic port 1 console

- MB nic port 2 vm traffic

- Quad port nic 1 ports 1-4 are vm traffic

- Quad port nic 2 ports 1-4 are iSCSI traffic

- ILO nic Port for remote access

Both 3750's are stacked together. Port 1 (3750A) is the uplink/trunk to the 5510. Port 3 of of 3750A is linked to the ManagementSwitch(hp).

Each ESX Host's ports are split up between 3750A and B physically. So 2 ports for each quad port nic go to 3750A and the other two go to 3750B. The extra vmware traffic port from mb nic 2 is connected to 3750A.

Each ESX Host's Console Port (mb port 1) and ILO are connected to the Management LAN. This switch also has all the apc, thermal monitoring devices mounted on it.

The DC has two nic ports attached to each 3750 switch at port 5.

Vlan config

Management LAN: 1001

iSCSI: 1000

Servers/Clients: 100

All routing is being handled by the 5510.

Each VM Machine Traffic port is configured:

interface GigabitEthernet1/0/26

description ESX02 L1 VM

power inline never

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100

switchport mode trunk

switchport nonegotiate

!

Each iSCSI

!

interface GigabitEthernet2/0/11

description ESX03 R3 iSCSI

power inline never

switchport access vlan 1000

switchport mode access

spanning-tree portfast

!

DC Connection

!

interface Port-channel10

description DCO1 - 10.100.10.5

switchport access vlan 100

switchport mode access

spanning-tree portfast

spanning-tree bpdufilter enable

!

!

interface GigabitEthernet1/0/5

description DC01 M1

switchport access vlan 100

switchport mode access

channel-group 10 mode on

spanning-tree portfast

spanning-tree bpdufilter enable

!

!

interface GigabitEthernet2/0/5

description DC01 M2

switchport access vlan 100

switchport mode access

channel-group 10 mode on

spanning-tree portfast

spanning-tree bpdufilter enable

!

Uplink to the Management Switch (HP)

!

interface GigabitEthernet1/0/3

description MGMT LAN 1 UPLINK

power inline never

switchport trunk encapsulation dot1q

switchport trunk native vlan 1001

switchport mode trunk

!

General:

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 100

name OFFICE_LAN

!

vlan 1000

name ISCSI

!

vlan 1001

name NETMANAGEMENT

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

ip address 10.100.10.254 255.255.255.0

!

interface Vlan1000

ip address 10.100.40.254 255.255.255.0

!

interface Vlan1001

ip address 10.100.30.254 255.255.255.0

!

ip default-gateway 10.100.30.1

0 Kudos
0 Replies