Sangokan
Enthusiast
Enthusiast

Upgrade to vcenter 2.5 problem with sql dsn

Hi,

I am trying to upgrade vcenter to version 2.5 but i get this error :

This DSN uses the 'SQL Server' ODBC driver. VirtualCenter requires the 'SQL Native Client' driver when using SQL Server 2005. Please install the 'SQL Native Client' driver and re-configure this DSN appropriately. See release notes for more information.

I have been looking for releases notes but cant find anything.

Can someone give a hand? Thanks

0 Kudos
3 Replies
jhanekom
Virtuoso
Virtuoso

The SQL Native Client driver is on the SQL 2005 and SQL 2005 Express installation media. All you need is to install "sqlncli.msi", which is under the "Setup" folder. (The SQL Express installation executable on VirtualCenter installation CD is in compressed form. You can extract it by running it with a "/x" parameter.)

You will then need to make sure that the ODBC DSN you create for your database uses this driver, and not the "SQL Server" driver.

0 Kudos
Sangokan
Enthusiast
Enthusiast

Ok mate, i installed the sql native client but i have been to the connection odbc properties and i have no idea how to configure the DSN to use the native client instead of the other one.

0 Kudos
J-H
Enthusiast
Enthusiast

vi3_35_25_installation_guide.pdf page 69.

You have to select the driver at the time you create the DSN.

0 Kudos