VMware Cloud Community
rbmimi
Contributor
Contributor

USB Keyboard not working after system boot up

We have a Dell PowerEdge 2950 that has the ESX 3.5 installed on it. After boot up we can choose to go into Troubleshooting mode, Debug or boot into the Kernel. When we go into the Kernel and we get the screen to press either Alt-F1 or Alt-F11, the keyboard does not work.

If we instead go into the troubleshooting mode the keyboard does work. But we can't do any configurations unless we do so with the Kernel loaded. It is a USB keyboard and in fact that is all the server supports. We have an APC KVM which is also USB and does not work so that is out of the question at the moment. I think we can go into Troubleshooting mode and make a change in the configuration to enable it but not sure where or how to do that. I am not a Linux/Unix person. USB is turned on in the Dell BIOS already.

Any suggestions on how to get this working? We basically have a problem because one of our virtual switches needs to be re-created and unless we can get into the kernel it is not possible. So in the meantime the system is of no use to us. We have one of our ESX servers online but the cluster is of no use until we get this ESX up.

Thanks in advance.

Tags (3)
Reply
0 Kudos
3 Replies
AndreTheGiant
Immortal
Immortal

Do you confirm that in BIOS the keyboad work fine?

Only in ESX 3.5 service console does not work?

From SSH have you tried to run:

modprobe hid

modprobe input

What's the output of lsmod command?

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
Reply
0 Kudos
TobiasKracht
Expert
Expert

Workaround:

There are two distinct workarounds, one for installation and one for

after installation. Both are required.

For installation, specify noapic at the initial installation menu. To do this

for graphical installation, rather than just pressing the enter key, type esx

noapic and press the enter key. For text installation, type ESX Server noapic text and

press the enter key.

After installation USB devices other than keyboard and mouse will not be

functional.

  1. Edit the file /boot/grub/grub.conf (save a backup of the file
    first) and replace the option noapic with vmnixACPI at the end of each of the
    lines that begin with the word kernel. The grub.conf file can only be accessed
    by the root account.

  2. When you have finished your edits save the
    /boot/grub/grub.conf file.

  3. Next edit the file /etc/modules.conf
    (again, save a backup copy of the file first). Add the following lines:

    • alias usb-controller usb-ohci

    • alias usb-controller1 ehci-hcd

  4. Save the /etc/modules.conf file.

  5. Reboot.

StarWind Software R&D

StarWind Software R&D http://www.starwindsoftware.com
Reply
0 Kudos
rbmimi
Contributor
Contributor

I didn't get a chance to try any of you guys suggestions because we have two ESX servers. ESX1 was unpingable on the network and we were unable to bring online one of the virtual switches. This was hanging up that server. So we went ahead and blew it all away and rebuilt it. After that was done the USB was functional completely for us again. That tells me that during setup a few months ago, the person who installed it must have turned off that function either intentionally or while locking down other features. In either case all is good now with that server. We now have to go into ESX2 and figure out where it was turned off and turn it back on.

Thanks for the suggestions.

Reply
0 Kudos