pavel_noga
Contributor
Contributor

Time synchronization with host

Hello, I have a problem with synchronizing virtual machine time with ESX server host.

I have a Linux virtual machine running on ESX Server 3.5. (Virtual machine was created from a physical machine vith VM Converter.) Virtual machine looks fine.

There are VM Tools installed in the virtual machine, VI client shows them as OK.

Time synchronization with host is configured (Settings | Options | VMware Tools | Synchronize guest time with host).

Time synchronization doesn't work, though. ESX server time is correct (it is maintained by NTP), but virtual machine time is not. Time differences are really huge, minutes :smileyalert: after ten minutes of virtual machine run.

Can anybody help?

0 Kudos
6 Replies
kjb007
Immortal
Immortal

Did yhou install the tools manually, or did converter do it? You can try to remove and reinstall the tools.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
0 Kudos
pavel_noga
Contributor
Contributor

We installed VM Tools manually. VM Converter created the virtual machine, after that we installed VM Tools (RPM package) in it.

0 Kudos
kjb007
Immortal
Immortal

What I would do is use NTP. There are time synchronization how-to available here: http://www.vmware.com/pdf/vmware_timekeeping.pdf that will offer some suggestions to things you can tweak inside the vm to keep time. While this has possibilities, I would use an external source, if one is readily available.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
0 Kudos
pavel_noga
Contributor
Contributor

We have already tried to use NTP inside the virtual machine. Rapid time diversion is the problem - even if we synchronize time (via NTP) every 10 minutes, there is still about a minute (or more) difference at the end of the time interval. Is it normal for a (Linux) virtual machine to behave like that?

We hoped it might do better if we configure time synchronization with the host. (Application running inside the virtual machine is very sensitive to correct system time.)

0 Kudos
kjb007
Immortal
Immortal

Ok, in the guide, there are some parameters you can tweak so time is kept a little better. It will include 3 kernel parameters that you can work through to see which one works best in your scenario. Check the linux section of the pdf.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
pavel_noga
Contributor
Contributor

Thank you for you recommendation, it helped. We used the kernel option clock=pit, virtual machine system clock behaves much better, but now it is about 3 seconds ahead of service konsole time (all the time). (This behaviour is still not acceptable.) Do you know how to fix this problem?

0 Kudos