VMware Cloud Community
Thorsten_Schnei
Hot Shot
Hot Shot

Strange behavior of Memory Usage of W2008/64bit-VM on HP DL385G5

Hi,

this one is a really strange one. Last week I deployed our first Windows 2008 64bit VM, running on ESX 3.5. Some time later I realized that in Virtual Center the VM was marked with an alarm (Virtual Machine memory usage high). Looking at the performance stats it turned out that the counters Memory Usage and Memory Active were at their maximums (VM has 1GB of memory assigned.

A reboot of the VM didn't solve the problem and a second VM running 2008 32bit didn't had this problem. Some time later I migrated that VM to another host and suddenly I realized that the VM showed the expected behavior for the memory usage (see below):

All hosts are running the same version of ESX and the problem is reproduceable (without a reboot of the VM). As soon as the VM is on a HP DL385G5 the memory usage stays at 100%. When the VM is moved to a DL 385G1 or G2 the problem goes away.

The VM is configured for the correct guest OS (Windows Server 2008 64bit). Funnily enough I changed the type to "Windows Server 2008 32bit" and the VM behaved as normal....

Has anybody seen that also ???

Cheers

Thorsten

Reply
0 Kudos
7 Replies
AWo
Immortal
Immortal

All hosts are running the same version of ESX

Including the patch level?

VMware Tools installed in the guest?


AWo

VCP / VMware vEXPERT 2009

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
Reply
0 Kudos
Thorsten_Schnei
Hot Shot
Hot Shot

All hosts are on exactly the same patch level.

VMware Tools are installed in the VM. I also removed them completely and re-installed without success.

Reply
0 Kudos
AWo
Immortal
Immortal

Can you post the .vmx file of the guest?


AWo

VCP / VMware vEXPERT 2009

vExpert 2009/10/11 [:o]===[o:] [: ]o=o[ :] = Save forests! rent firewood! =
Reply
0 Kudos
Thorsten_Schnei
Hot Shot
Hot Shot

Here is the config file:

#!/usr/bin/vmware

bios.bootDelay = "10000"

config.version = "8"

deploymentPlatform = "windows"

displayName = "W2K8_x64_STD_SP2"

ethernet0.addressType = "vpx"

ethernet0.features = "15"

ethernet0.generatedAddress = "00:50:56:b8:4c:3e"

ethernet0.networkName = "VLAN200"

ethernet0.present = "true"

ethernet0.virtualDev = "vmxnet"

evcCompatibilityMode = "TRUE"

extendedConfigFile = "W2K8_x64_STD_SP2.vmxf"

floppy0.clientDevice = "true"

floppy0.fileName = "/dev/fd0"

floppy0.present = "true"

floppy0.startConnected = "false"

guestCPUID.0 = "0000000568747541444d416369746e65"

guestCPUID.1 = "00020f100000080000000001078bfbff"

guestCPUID.80000001 = "00020f1000000b8f00000000e3d3fbff"

guestOSAltName = "Microsoft Windows Server 2008 (64-bit)"

guestOS = "longhorn-64"

hostCPUID.0 = "0000000568747541444d416369746e65"

hostCPUID.1 = "00100f230004080000802009178bfbff"

hostCPUID.80000001 = "00100f2300000b8f000007ffefd3fbff"

ide0:0.clientDevice = "true"

ide0:0.deviceType = "atapi-cdrom"

ide0:0.fileName = ""

ide0:0.present = "true"

ide0:0.startConnected = "false"

memsize = "1024"

migrate.hostlog = "./W2K8_x64_STD_SP2-680e3bac.hlog"

nvram = "W2K8_x64_STD_SP2.nvram"

powerType.powerOff = "default"

powerType.powerOn = "default"

powerType.reset = "default"

powerType.suspend = "default"

sched.scsi0:0.shares = "normal"

sched.swap.derivedName = "/vmfs/volumes/4a48cebd-160f6782-3f5e-001f295b509e/W2K8_x64_STD_SP2/W2K8_x64_STD_SP2-680e3bac.vswp"

scsi0:0.deviceType = "scsi-hardDisk"

scsi0:0.fileName = "W2K8_x64_STD_SP2.vmdk"

scsi0:0.present = "true"

scsi0:0.redo = ""

scsi0:1.deviceType = "scsi-hardDisk"

scsi0:1.fileName = "W2K8_x64_STD_SP2_1.vmdk"

scsi0:1.present = "false"

scsi0.present = "true"

scsi0.sharedBus = "none"

scsi0.virtualDev = "lsilogic"

toolScripts.afterPowerOn = "true"

toolScripts.afterResume = "true"

toolScripts.beforePowerOff = "true"

toolScripts.beforeSuspend = "true"

tools.syncTime = "false"

tools.upgrade.policy = "useGlobal"

userCPUID.0 = "0000000568747541444d416369746e65"

userCPUID.1 = "00100f230004080000000001078bfbff"

userCPUID.80000001 = "00100f2300000b8f00000000e3d3fbff"

uuid.bios = "50 38 2a 3d f2 93 ae 6a-ef ff c6 8e 75 6f 85 b2"

uuid.location = "56 4d 8a fa 8b 34 a7 38-c5 65 6f d8 b4 cb d8 22"

virtualHW.productCompatibility = "hosted"

virtualHW.version = "4"

Reply
0 Kudos
Thorsten_Schnei
Hot Shot
Hot Shot

I raised this issue with VMware Support and they confirmed that this is a bug. Looks like the AMD Barcelona CPUs are affected by this and they are already working on a fix. Workaround is as follows:

<![endif]><![if gte mso 9]>

"On the affected ESX Server, select "Configuration"

-&gt; "Advanced Settings", and change the Mem.AllocGuestLargePage to

0. The Memory alarms will then no longer present. If the Memory alarm does not

clear, it may be necessary to restart the ESX management agents. See for

details."

Haven't tested that yet.

Reply
0 Kudos
RMGZL
Contributor
Contributor

Hi, is there a KB article from VMware regarding this bug (for ESX 3.5), as I am experiencing the same behaviour on our DL585 G5's?

Reply
0 Kudos
Thorsten_Schnei
Hot Shot
Hot Shot

Hi,

there might be a KB article. But I know that this issue was solved by a patch. So you should be able to get rid of it by upgrading to the latest update level.

Thorsten

Reply
0 Kudos