PKaufmann
Enthusiast
Enthusiast

Strange Problem with VMotion and VLANs

Hi there,

I have a very strange problem with VMotion and VLANS ..

First a description of our esx environment:

  • 9 ESX Servers (Dell PowerEdge 2950)

  • Service Console and VMotion is in one vSwitch

  • Two NICs are configured for that vSwitch

  • Service Console Network-Range: 172.16.2.x

  • Service Console VLAN: 15

  • VMotion Network-Range: 172.16.30.x

  • VMotion VLAN: 6

esxcfg-vswitch -l:

Switch Name Num Ports Used Ports Configured Ports Uplinks

vSwitch0 32 5 32 vmnic1,vmnic0

PortGroup Name Internal ID VLAN ID Used Ports Uplinks

Service Console portgroup0 6 1 vmnic1,vmnic0

VMotion portgroup12 15 1 vmnic1,vmnic0

we are using 2 Cisco 3750 Switches and have configured our vlans on the switch:

example:

interface GigabitEthernet2/0/18

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 6,15

switchport mode trunk

All Ports on the Cisco Switch are configured that way!

Here is the strange thing:

It worked for 4 ESX Servers, 2 are not working... I can reconfigure the other ESX Servers until these 2 are working..

These 2 servers don´t get the VLAN 15, I don´t know why ...

do you have any ideas?

0 Kudos
2 Replies
bhadzik
Enthusiast
Enthusiast

Every time I have run into VLAN issues with cisco, it has been resolved with changing the default vlan on that switch port. Not sure why that fixes it, and it usually is a problem with VLAN 1, but it has fixed it on more than one occasion.

0 Kudos
PKaufmann
Enthusiast
Enthusiast

Hi,

as you can see, we are using VLAN 15 and VLAN 6, not VLAN 1 ..

I solved the problem after bringing the vmknics up and down serveral times ...

Thread can be closed...

0 Kudos