charger
Contributor
Contributor

So confused...any help with ESX3?

Hi,

I have ESX3 installed on a remote machine and am trying to connect to a console for one of the VM's running on said ESX3 host. My local client is linux 2.6.20. I have tried:

Using the web interface: The mks plugin for firefox just gives me a large white square instead of a console.

vmware-console for linux doesn't seem to work with ESX3 (can't execute vmware-serverd)

Is there a way for me to connect to a ESX3 VM console from a linux client?

Any help is greatly appreciated!

Thanks

Mike

0 Kudos
3 Replies
admin
Immortal
Immortal

No, there is no Linux client for ESX3. Not sure why you can't get the Web Interface working....works for me on FC5 with Firefox. Are you running the latest version of Firefox? Are you running 32-bit or 64-bit Firefox? I believe there are issues with teh web access and the 64-bit version.

I found these tips on here related to the web access and firefox.

>>-The install didn't work because of an error with libcrypto. So I did the download/rename/unzip drill and copied all files to /home/user/.mozilla/plugins/. Should work with the system wide plugin directory as well.

>>-Because it didn't work after that I did a strace and a "ldd /home/user/.mozilla/plugins/libmks.so" and it turned out that libexpat wasn't found.

>>-On this system libexpat was installed in a newer version and symlinked from /usr/lib/libexpat.so.1. Because libmks.so is looking for libexpat.so.0 a "cd /usr/lib" and "ln -s libexpat.so.1.5.0 libexpat.so.0" fixed that.

>>Now the plugin works fine for me.

Afraid, otherwise, you are going to need a Windows machine to run the VI client on - if you don't have one you can use I suggest installing VMware Server on your Linux box and installing a Windows VM.

Browse to https://yourEsxorVcserv.com/ to download the VI client.

0 Kudos
charger
Contributor
Contributor

I've tried firefox 2.0.0.2 and 1.5 (just in case).

The mks plugin install package (.xpi) fails on both with:

Firefox could not install the file at file:///root/vmware-mks.xpi

because: Cancelled

grrrr...

So I unpackaged the .xpi and manually put it in the firefox plugins directory....

The plugin loads but like I said, I get a big white box on the console tab.

I'll keep monkeying with it...very frustrating....

mike

0 Kudos
zorong
Contributor
Contributor

I may be able to solve this one. I couldn't get it to work either, on FC5, with Firefox 1.5.0.10: when clicking the console tab, I'd only get a gray rectangle.

In a nutshell, I did a bunch of stracing to see what goes wrong when the plugin is supposed to be executed, and it seemed clear that the execve() command is f*cked:

execve("/usr/lib/mozilla/plugins:/usr/lib/firefox-1.5.0.10/plugins/viewer", \["/usr/lib/mozilla/plugins:/usr/li"...], )

= -1 ENOENT (No such file or directory)

After this failure, the child process that's supposed to run "viewer" just exits.

Obviously "/usr/lib/mozilla/plugins:/usr/lib/firefox-1.5.0.10/plugins/viewer" is not a valid path but rather two combined, so I forced it to look like a single one:

\# cd /usr/lib/mozilla/plugins

\# ln -s / plugins:

Then I copied all the plugin's files from the installation in my home directory over into /usr/lib/firefox-1.5.0.10/plugins/:

\# cd /usr/lib/firefox-1.5.0.10/plugins/

\# cp ~/.mozilla/plugins/* .

Restarted Firefox, and it worked. I don't know what goes wrong in the code but clearly vmware should sanity-check their execve() invocation.

Hope this helps.

0 Kudos