johnlennon
Enthusiast
Enthusiast

Setting tools.syncTime for all VMs on a host - broken on ESX 3.5

In previous versions of ESX up to 3.0.2 I could use this command:

vmware-cmd -l | xargs -i vmware-cmd {} setconfig tools.syncTime "TRUE"

to force the VMware tools in each VMs on a given ESX server to sync the time with the host. This was working fine, but it looks like it's broken in 3.5. The command executes and claims success but it doesn't work: the VMX file is not updated, the option in the tools isn't set.

Is there a way to quickly accomplish the same? I have 100s of VMs that could be affected and I need to be able to change them. Note that I tried to write a shell script that modifies the VMX file, however this works only for powered off VMs, as for powered on, the setting is overwritten after a while.

0 Kudos
3 Replies
johnlennon
Enthusiast
Enthusiast

0 Kudos
mfiedler
Contributor
Contributor

I followed the link posted, but was unable to decipher how you fixed this issue.

I am seeing the same problem now, as the templates we initially used did not have the Sync Time set to true (and there's a lot of *nix guests there too).

Help?

0 Kudos
admin
Immortal
Immortal

First, you'll need to download and install the VI Toolkit from

Once you've installed it, start the toolkit and log in to your environment using the connect-viserver command. Then you can copy and paste that code in and update your VMs.

0 Kudos