Tidian
Enthusiast
Enthusiast

Scripted installation of ESX 3.5

Jump to solution

Hi there,

I'm installing ESX 3.5 update 5 via script (unattended installation via http).

During the installation the failback policy should be set from default "yes" to "no".

I'm trying to do this with command: vmware-vim-cmd hostsvc/net/vswitch_setpolicy --nicteaming-rollingorder=false vSwitch0

After the installation the policy was not changed and is still set to "yes".

So I executed the command in the service console and the after few seconds the prompt is back. In the Infrastructure client "Recently Tasks" shows that the switch settings has been refreshed, but the policy was not changed and is still set to "yes".

What is wrong with command?

Thanks for help.

Tino

0 Kudos
1 Solution

Accepted Solutions
nirvy
Commander
Commander

Hi Tino

If you want Failback: No, then you need to use:

vmware-vim-cmd hostsvc/net/vswitch_setpolicy --nicteaming-rollingorder=true vSwitch0

View solution in original post

0 Kudos
6 Replies
nirvy
Commander
Commander

Hi Tino

Have you tried adding the path to the vmware-vim-cmd binary? e.g.:

/usr/bin/vmware-vim-cmd hostsvc/net/vswitch_setpolicy --nicteaming-rollingorder=false vSwitch0

0 Kudos
Tidian
Enthusiast
Enthusiast

Yes, I have tried the absolute path of the command, but nothing has been changed.

0 Kudos
nirvy
Commander
Commander

Can you attach your script?

0 Kudos
Tidian
Enthusiast
Enthusiast

I have attached the script.

0 Kudos
nirvy
Commander
Commander

Hi Tino

If you want Failback: No, then you need to use:

vmware-vim-cmd hostsvc/net/vswitch_setpolicy --nicteaming-rollingorder=true vSwitch0

0 Kudos
Tidian
Enthusiast
Enthusiast

Hi Nirvy,

thank you for your help! It's working now!

That's strange, that this parameter must be set to "true".

Tino

0 Kudos