retro_tech
Contributor
Contributor

SAN Replication / Datastore Issues

We have two Equallogic SAN's, and I am setting up replication between

them. All of the DR scenarios that I am testing have worked without a

problem, except when I try it with ESX. This is the process I am

following:

1. I replicate a test volume that contains a VM from EQ1 to EQ2.

2.

I promote the replica on EQ2 to a volume, without retaining the

original target name and also promote it while leaving it offline.

3. I demote the original volume on EQ1, and then make the volume promotion permanent on EQ2, then set it online.

4. I add an iSCSI connection on the test ESX server to EQ2, rescan all HBA's and then add that volume.

5.

The datastore shows up on the ESX server, but it doesn't recognize the

volume as having any data on it. When I browse the datastore it shows

no data as being there.

Any ideas?

0 Kudos
4 Replies
retro_tech
Contributor
Contributor

bump

0 Kudos
xenfro8
Contributor
Contributor

we use EMC and they provide a software called Replication Manager that automates the whole thing, check with equallogic if they have something similar.

0 Kudos
pnavahal
Contributor
Contributor

When u promoted the replica make the target online try it out.

Second if u have and functionality like volume copy (IBM) or san copy (EMC) between storage try it out. SANCopy work between different vendors like hp dell emc and ibm.

also let me know ur san and lun configuration may that can help us to determine the problem.

0 Kudos
manfred_w
Enthusiast
Enthusiast

if you assign a replicated LUN to a new ESX you have to resignature this LUN:

in the VI Client: ESX -> Configuration -> Advanced Settings -> LVM -> LVM.EnableResignature "1"

then rescan

after that set LVM.EnableResignature "0" again.

or via command line:

---

# pwd

/proc/vmware/config/LVM

# cat EnableResignature

EnableResignature (Enable Volume Resignaturing) :

0

# echo 1 > EnableResignature

# esxcfg-rescan vmhba2 // hba you wanna scan

Rescanning vmhba2...done.

On scsi6, removing: 0:0 0:1 0:2 0:3 2:1 2:10 2:11 2:12 2:13 2:14

2:15 2:16 2:17 2:18 2:19 2:2 2:20 2:21 2:22 2:23 2:24 2:240 2:241

2:25 2:26 2:27 2:28 2:29 2:3 2:30 2:31 2:32 2:33 2:34 2:35 2:36

2:37 2:38 2:39 2:4 2:40 2:41 2:42 2:48 2:49 2:5 2:6 2:7 2:8 2:9.

On scsi6, adding: 0:0 0:1 0:2 0:3 2:1 2:10 2:11 2:12 2:13 2:14 2:15

2:16 2:17 2:18 2:19 2:2 2:20 2:21 2:22 2:23 2:24 2:240 2:241 2:25

2:26 2:27 2:28 2:29 2:3 2:30 2:31 2:32 2:33 2:34 2:35 2:36 2:37

2:38 2:39 2:4 2:40 2:41 2:42 2:48 2:49 2:5 2:6 2:7 2:8 2:9.

# echo 0 > EnableResignature

---

after that you should have access to the vmfs file system.

0 Kudos